New Xenon, and Spectra Xenon stuck in Listening, no USB serial

@ScruffR and @rickkas7, please read. My Spectra Parti-Badge ("#2) has been stuck in Listening mode for a few weeks, but still has the parti-badge app. But it hasn’t been posting data…
My Spectra Xenon-Featherwing (#1) ethernet gateway was breathing cyan, but today that’s gone to a very-fast flashing green, and it’s no longer posting to the cloud.
First of my new pre-order Xenons (#3) is out of the box, the new version of IOS app can now scan the data matrix, but then fails the bluetooth provision, so is never added to my new devices.
At this point, Neither #1 nor #3 can be seen via USB, so the particle CLI isn’t any use…
I do have the USB debugger board, but don’t know what to to with that yet…
I think I need to try to update the code on all three, and I’m going back through the forums trying to find clues. (I’ve got 5 Argons and a dozen more Xenons to get through, when I figure out how to do it…)
Have I’ve missed the magic article? I’ve found the Known Issues article, and the repository with the new RC code… but I’m not sure how to get the new code in when the CLI isn’t working, and the claiming process doesn’t work. There’s a need for a “How to get your pre-order gear up and running”. (Maybe update the HerokuApp? I think there are a few more steps needed.)

Are you able to put the devices into DFU mode? You might be able to update the firmware with dfu-util.

1 Like

I haven’t read about what to do after the Mode is set… if it’s not appearing on USB, I’m not sure how code is going to get to the chip… Do you think putting it into DFU mode will wake the USB? Or is that a mode for the Debug cable?

OK, #3 (new pre-order Xenon) is in blinking-yellow mode, USB came online, but no response to “particle serial identify”.

DFU Util is now installed;
C:\Users\v-zonkeh>dfu-util -l
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Found DFU: [2b04:d00e] ver=0250, devnum=15, cfg=1, intf=0, alt=2, name="@External Flash /0x80000000/1024004Kg", serial=“e00fce6823183e757d1bf0d6"
Found DFU: [2b04:d00e] ver=0250, devnum=15, cfg=1, intf=0, alt=1, name=”@DCD Flash /0x00000000/1
016Ke", serial=“e00fce6823183e757d1bf0d6"
Found DFU: [2b04:d00e] ver=0250, devnum=15, cfg=1, intf=0, alt=0, name=”@Internal Flash /0x00000000/1004Ka,47004Kg,192004Kg,4004Kg,4004Kg,8004Ka", serial=“e00fce6823183e757d1bf0d6”

I’ve got the Xenon new RC .bin file… Looking for the incantation to try to load it…

You can use:

particle flash --usb path-to-the.bin

That's to be expected, since for particle serial identify the device has to be in Listening Mode (blinking blue). But with device OS firmware before 0.8.0-rc.25 not all serial features were supported.

So in order to have full access to the serial features, you should update the device OS firmware to 0.8.0-rc.26 via DFU Mode and particle flash --usb system-part1-[....].bin

Binaries can be found here

Bootloader and Argon NCP update need to be applied via particle flash --serial (in Listening Mode).


I finally had to try with a Mac, had to install homebrew, got particle CLI and dfu-utils installed, and got RC.27.

I did get one of my devices (the one that took the upload to RC.26) to .27. When I tried to update dht esecond one (my Parti-Badge), it never left DFU Update (flashing yellow). When I finally pressed the reset, I get the red SOS #1). :frowning: I can get it into the clash update,and it says it’s taking the RC.27, but it still sits in flashing yellow.

I’m using the Hybrid RC file… should I flash a different file, and see if that helps? (Prior to the update, it was still a Parti-badge, in listening mode, but did not see my gateway…

I’m considering trying a full factory reset,and stat over with the network config. But at least I have a working toolset.

I usually use the non-hybrid system-part1. After that it's normal for the device to stay in DFU Mode since it waits for an application binary to be flashed next. I usually use the serial1 debug Tinker.

Thanks, but you’re walking me into deeper water. Please stay with me here. :slight_smile:

What you say makes sense (about loading hybrid, and then it stays in Update mode…), but I didn’t get any ideas about adding a second upload in the instructions for RC.27 (where I was reading about how to do this particular update).

I do have the 10-pin debug cable with my pre-order, but I’ve not used one before. (I have used the 6-pin connection on many Arduino boards with an FTDI-friend USB interface and the Arduino IDE… but I have only seen references to other interfaces which will talk to the debug interfaces.) This was my first efforts using DFU-util. I can learn. :slight_smile:

I’ve pulled the two files that you suggested here (for both Argon and Xenon) from the RC.27 repository, and I’ll try to flash them in that order. Thank you for the clues!

I set up my #1 and #2 boards at Spectra, and I’m not sure what the network info is (name, password), so would you recommend that I do the upgrades above, and then a Factory Reset to start over? or is there a better way to (unclaim and claim again?) to get to the section for setting up on new mesh credentials? (Is any of this worth including in the #FAQ, or in the pre-release Release Notes for future versions? :wink:

  Best regards, and happy hacking!

That's an important piece of info. If you are updating an Argon from anything before rc.25 to rc.25 or above, you also need to update the NCP (Network CoProcessor).
For that you need to download these files

And then you need to perform these commands in order
In DFU Mode (blinking yellow)

particle flash --usb system-part1-0.8.0-rc.27-argon.bin -v
particle flash --usb tinker-serial1-debugging-0.8.0-rc.27-argon.bin -v

In Listening Mode (blinking blue)

particle flash --serial bootloader-0.8.0-rc.27-argon.bin -v
particle flash --serial argon-ncp-firmware-0.0.5-ota.bin -v

For the Xenon you do respectively

In DFU Mode (blinking yellow)

particle flash --usb system-part1-0.8.0-rc.27-xenon.bin -v
particle flash --usb tinker-serial1-debugging-0.8.0-rc.27-xenon.bin -v

In Listening Mode (blinking blue)

particle flash --serial bootloader-0.8.0-rc.27-xenon.bin -v

You shouldn't need to unclaim/reclaim the devices, you can just set them up as if they were new, even if they are already claimed to your account.


Ho-boy! (Just keep swimming. Just keep swimming. Just keep swimming… :wink:

OK. More files to get, but more “framework” knowledge for the notebook. :slight_smile:

If I get my way, I’ll be working (as a volunteer) on the Train of Lights tonight, and Thursday would be the next change to get the bench online again. I’ll update after that.

In total, I’ve got a dozen pre-order Xenon and 5 Argon to try to claim and get updated. The first steps are getting my first two back online, and (hopefully) figure out how to re-load one Xenon with the Parti-Badge code. THEN I’ll be ready to start hacking with sensors, and local-network publish and subscribe, adding FastLED or NeoPixel code, and the Adafruit OLED or TFT display wings… :slight_smile:

One step at a time...
1 Like

Looking closer to @ScruffR’s reply for updating older (pre-RC.26) boards, I spotted the links in the xenon section are for the Argon code, but the CLI section was still correct. I’m only calling this out as a caution.

When I read the reply the first time, my mind overlooked the “argon” parts in that section and filled in the “Xenon” words. I only saw it when I came back, and looked very closely, to make sure I was ready to try to recover my Spectra “S-O-S #1” Xenon…

When I reply, is this in the thread for all (I hope so!), or is it a one-to-one reply?

My SOS #1 is clear, and I'm back to Listening mode with Xenon #2! (Any clues about putting my Parti-Badge code back on? At this point, I'm guessing #2 doesn't know about my network, either.... I think it's time to set up a new set of network credentials on #1, add #2 to the network, then update Xenon #3 (net-new that wouldn't complete the network set-up process to #1 before) to the network...

The " -v" flag was great! It obvious in hindsight, but I hadn't seen it in earlier postings. For those who don't know, adding the " -v" (remember the leading space there) sets "verbose mode", giving you more details about the processes of those commands you run with dfu-util, which can help the experts figure out the problem if things do not go as expected. Here's an example of the output when things worked as expected;

zonkers-imac:particle zonker$ particle flash --usb tinker-serial1-debugging-0.8.0-rc.27-xenon.bin -v
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util / Tickets

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Opening DFU capable USB device...
ID 2b04:d00e
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash "
Downloading to address = 0x000d4000, size = 13716
Download [=========================] 100% 13716 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state

Flash success!

1 Like

Thanks for the heads-up :+1: I corrected the links.

It is a public thread. Private messages wouldn't show up in the public thread list and would also feature an :email: icon in the title bar next to the Particle :particle:

You can look here

1 Like

Hooray! Thanks @ScruffR for the clues. <feeling accomplished!>

I'm happy to report my current status;
Xenons #1 thru #4 are all up to RC.27 code, following the instructions for bootloader and etc.
(That process worked fine for the pre-order parts (#3, #4), though maybe they were on RC.26?)
Xenon #1 is in the particle Etherwing at home. #2, #3, #4 can all breathe cyan... :slight_smile:
(I did create a new network, and migrated them without needing to unclaim and claim again)
I'll wait a little bit before updating (m)any more of my pre-order parts...

All full of confidence, I looked around the Particle Github,and found the Parti-badge repo..., and pulled down the ZIP file...
I put my badge in DFU mode...
from the "binaries" folder, I first loaded the system part 1 bin file...
the, inside "binaries/appication-firmware", I loaded the firmware.bin file...

particle flash --usb binaries/system-part1.bin -v
particle flash --usb binaries/application-firmware/firmware.bin -v

After the badge rebooted, the badge functions are back, it found the mesh network, and is breathing Cyan!

To-Do next:
Try adding some i2c sensors to #3, and try posting data to the cloud...
Re-photograph my other pre-order data matrices (contrast too poor on the first attempt for many)