Xenon Lost Mesh Settings - Unable to Connect/Reconfigure


Last night the battery on my (working and connected) Xenon went flat and today on power up it goes straight to flashing blue set-up mode, but now I’m unable to configure it and get it to reconnect.

I’ve tried with my phone to re-add the device but my phone gets stuck at “Pairing with your Xenon” - tried on 2 phones, including the one that originally configured the device.

I am able to connect to it via the serial port and issues an “i” command to get it’s identity, but I don’t see an option to reconfigure the mesh settings to get it reconnected.

It’s running firmware 0.8.0-rc.27

Claims MAC address as 00:00:00:00:00:00

Is there something I can do via the serial port like the “w” WiFi command to get this device to reconnect? I went through the alphabet and nothing appeared to work. Or some other trick to reconnect this device?

Just to make this even more annoying, the Xenon is soldered to the PCB (due to lack of space in the enclosure) so I can’t just swap it out with another one :frowning:

Also, off topic, but in the interest of project sharing here’s a photo of what I’m working on…

Yes that’s a CCS811 and a BME680 as well as some other fun sensors :slight_smile:

Also… bonus tip: be-careful when using a hot air rework gun near your Xenon, turns out those labels are thermal… Fortunately I’ve got a photo of the device with the QR code so not all is lost!.


That looks cyan on the photo - this would mean your device is connected to a gateway (or router node).
But you can clear the credentials when you press/hold MODE then tap RESET and keep holding MODE till the RGB LED turns white.
After that you should be able to setup the device again.

Just out of curiosity, do you get reliable eCO2 readings of that CSS811? If so, how?
On all sensors I’ve used so far (with Photons tho’) I did get massive drift after a few minutes.

BTW, there doesn’t seem to be a lot of solder on the Xenon pins (as far the photos tell).

1 Like

Hi @ScruffR thanks for your reply.

I had a bad feeling when posting those photos it would confuse things. The photos are before it was soldered and then after being soldered when it was working, connected and sending data (hence the cyan color).

Currently it’s blinking setup blue straight after power up. I’ve gone through the white LED and it still goes back to blue and the app is refusing to talk to it. Hence, I was hoping there was a serial trick to set it up like their is with the Photon before I upgrade it to being a door wedge…

The CCS811 appears to be ok, they needs 20 or so minutes to stabilise after power on, then you need to do a baseline in clean air (and you need to do that every so often). It also needs about 24-48 hours on time for an initial burn in.

Here’s a chart from the actual device, red line is light level and purple is eCO2, you can see when I got into my office (lights on, me breathing out CO2), then I go off and do things, then back again. Nice clean baseline when I’m not in the office!.

And just in-case you’re interested, here’s the CCS811’s VOC reading vs the BME680’s gas resistance…

(I think their from the same dataset / date range).


1 Like

As long you can put the device into DFU Mode, you should be able to resurrect it.
Just compile this little sketch and flash the resulting binary to it

#include "Particle.h"
#include "dct.h"

void setup() {
    // This clears the setup done flag on brand new devices so it won't stay in listening mode
    const uint8_t val = 0x01;
    dct_write_app_data(&val, DCT_SETUP_DONE_OFFSET, 1);

    // This is just so you know the operation is complete
    pinMode(D7, OUTPUT);
    digitalWrite(D7, HIGH);

After that your device should think it was already setup successfully and putting into Listening Mode manually should work again.

Otherwise you can go through this procedure (the Xenon part) to manually flash the device OS, bootloader and factory application (aka Tinker)

1 Like

Magic, I’m back up and running, thanks @ScruffR

I ended up going through to flashing the device os, boot loader and tinker, I’d like to say that was the fix, but at the point I also realised that I might have been scanning the QR code from a photo of a different Xenon!, having thermally destroyed the devices actual label previously.

So the set-up non functionality might just be an epic Steve Fail, however the original failure, the loss of mesh credentials/connectivity definitely wasn’t my fault!

As a side note, it would still be really useful to have the serial setup, like the “w” wifi command for the Photon, that’s saved me a heap of times (not least because I have multiple Particle accounts and it’s a real pain to switch between them in the app, or I don’t have the password with me when I’m out trying to get a Photon connected to another WiFi network.

Anyway, Thanks for your help! :slight_smile:

1 Like