Can not redo setup via app

I would very much appreciate some ideas to move on from where I am currently (blocked in setup).

I have set up a Argon (mesh and wifi) with the android app, everything worked (connection, can program and execute code).
I then set up a Xenon to use the same mesh, and this initially worked (programming and uploading code via WEB-IDE) and gave me published events.
At some point the Xenon stopped connecting and after hours of trying I decided to reset to factory (two bottoms white flashing LED), after this the Xenon is in the initial state as expected (flashing blue).
BUT no matter what I do I can not get it to connect again using the app…
Some extra info:
the Xenon is all ready in the list of devices in the app, do I need to delete it to redo the setup (how) ?
If I go one with a setup of new device (despite the above) I can scan the QR code and it will connect and it will find the Argon’s mesh network, but it then tells me the phone will work as a commissioner for the mesh and I will need to scan the QR code of another Xenon ??? (don’t have one, tried scanning itself or the Argon, to no help) it all ends with a spinning star saying connecting to your Xenon, for hours (yes I left it for +60Min).
I have tried flashing firmware (hybrid-0.8.0-rc.25-xenon.bin), makes no difference.

BR and apologizes if my questions are due to ignorance :slight_smile:
slinBin

Ps: what is “unclaim” will it help me starting from scratch to unclaim the device ?
How do you manage existing mesh networks ?
How do I redo the setup of the Argon (WiFi and mesh) ?

I wouldn’t un-claim the device. That’s not usually beneficial and causes more problems.

What you describe is mostly correct. Try to re-add the Xenon with the mobile app by clicking on the “+” symbol and selecting mesh (ignore that it’s already in the list of devices). When it asks for an “Assisting device”, you put the Argon into listening mode (hold Mode button for 3 seconds until blinking blue) and then scan the QR code of the Argon. From there, you would see a screen saying “scanning for mesh networks” and then you click on the existing mesh network on the Argon. When you get to the “Assisting device” screen, you may scan the Argon and it will erroneously say something about using a Xenon… which is a bug and you can ignore that. It sounds like you already tried that. I thought the assisting device was a bit confusing at first and I had to restart the process a couple of times before I got it perfect. I would say, try again, and then confirm back here if it worked or not.

At this time, you don’t. You can create new mesh networks by stepping through the setup on a gateway again. Or you can add Xenons to an existing mesh. Those are the only 2 options at the moment.

Same as for the Xenon, just go to the mobile app, click the “+” for add new device and select “Mesh”. Walk through the app again. Note: you will have to create a new mesh network if you do this for a gateway. There’s no way to add a gateway to an existing mesh at this time.

1 Like

SOLVED Thank you !

For reference:
I did as described using the Argon in “Blue flash”-mode as reference.
After requesting mesh password:
I got a screen in the app, stating:
-“Your Xenon is joining the mesh network”
-“Requesting permission from assisting device to add Xenon”
-"Adding Xenon to the mesh network (does show up in the console as active)"
it did not not go beound a grayed aout “starting a secure session with the Particle Device Cloud via gateway” (Xenon is flashing white, Argon is back into normal “connected” mode).
At this point I pulled thepower on both devices and powered up the Argon and then the Xenon.
Now things appear to be back to normal :slight_smile:

1 Like