Trouble with adding second xenon joining a network

I just updated 2 xenons and an Argon to 0.9.0 and have been trying to get them all on the same network. Very frustrating.
How do you get rid of an existing network with no devices attached to it?

It seems like adding another xenon to an existing network does not work according to the instructions.

I released all of them from their networks using the quick flashing blue led procedure, and no matter where I start, from the Console (add device to network) or from the mobile app (iphone) I run into a wall one way or another. I thought by now all these things would be coordinated.

So, I’ll just try getting rid of all the old networks registered and start over. How do I get rid of a network. All my devices are unclaimed, so this should not prevent me from getting rid of all of the networks. I just don’t know how to do it.

Actually, the console lists one device for each network…but I don’t have any claimed devices. How can that be? If I list my devices, it says none.

When trying to add devices to an existing network using the phone app, it reported different errors, like Associated device is on a different network than the one you are trying to join. This is even when the device has no network assigned to it, and I just paired with the assisting device by scanning the qr sticker. How can it say it is a different network?

Another error was encountered when trying to add an argon as a gateway to an existing network using the iphone app. The error said you are trying to add to an existing network. Of course I was. That is what I was trying to do. The iphone app did not ask if I wanted to add to an existing network or a new one. It just assumed I wanted to make a new network, even though I started the process of adding another gateway through the console, starting with addd a gateway device to a network.

So, how do I get rid of all networks, even those who erroneously say they have one device in the network?

I created a new network, and added 2 xenons to a network with an Argon as the gateway. Since I added them all during the same session using the iphone app, it worked ok.

There are problems in the setup programs that do not easily allow another device to be added to an existing network. I am surprised that we are in half way through the first quarter of 2019 and these kinds of issues have not been solved. They existed in December.

Hopefully someone at Particle can see that it is frustrating to try to setup devices over and over in attempts to get them connected to a mesh network. This is basic stuff, I would think.

Finally, how do I get rid of all the old networks I have tried to set up since December…even the ones that say they have one device attached to them, but there are none really?

@ParticleD, or @mstanley are you able to assist?

You should not unclaim your devices, doing that will keep your mesh networks in limbo.
Currently you cannot disconnect a node from a mesh any other way than by assigning it to a new network of yours.
This quirk should be fixed, but if you don’t want to pass your device on to anybody else, just don’t unclaim it. You can re-claim your own devices over and over without ever unclaiming it.
Just claim it and assign it to a new network, this should then remove it from your networks. But you can’t fully remove a device from your network while it is not yours.
Also you should first remove all “client” nodes before you remove the gateway from the mesh.

That would currently be setting up a HA (high availability) network with is not yet supported.

That might appear to be the case but in most cases we came across it’s not that it wouldn’t work but that the instructions are not very clear and the users usually miss some of the nuances of that less than clear set of instructions.

A similar question is addressed in this post

Thank you KyleG and Scruffr for your helpful assistance.

I would like to explain something. Why would I want to unclaim a xenon? I tried countless times to add xenons to existing networks, following the brief instructions given in the Console for adding devices (which merely instruct you to use the mobile phone apps to setup your devices), and the setup instructions in the iphone app. Invariably, the process of adding one of my xenons to a network run into one error or another which merely give you the option to retry or start over. How can this be acceptable?

After trying this over and over, and releasing 2 xenons and one argon from their previous network connections using the procedure (fast blinking blue LED) and starting over with a new network, starting with the argon, then the two xenons, I was able to get them all in the same mesh as long as I set them up one after another in the same iphone app setup session. If I added one argon, then one xenon and ended the session, and later tried to add another, I got one of the two errors mentioned previously, and was unable to add another xenon to the network. I believe I followed the simple instructions carefully. If there are some hidden nuances that have to be known, they should be explicit and obvious.

Because of the perseverance and generosity of help of elites like Scruffr, I will stick with Particle mesh, but I have to admit that it has at times been frustrating. I think that if one of your experts in iphone apps would put a little more time into the iphone app, and ask the user if he wants to add this device to an existing network or create a new network (then make sure this works) it would help greatly.

Thank you for hearing me out. I also want this technology to work well. That’s why I flew to the 2018 Spectrum conference last fall.

Not sure if someone mentioned that to you before, but there actually is one step over which multiple users have already stumbled and which I have repeatedly “complained” the fuzziness of the instructions.

Once you have setup the new node device the mobile app asks you to scan the data matrix of a Xenon. Multiple people understood this as instruction to re-scan the data matrix of the new device but it should actually be another device which is referred to as “the assisting Xenon” (although it can also be the Argon or Boron gateway which I usually prefer as it is typically more reliable). This should enable the new device and the assisiting device (which both have to be blinking blue at that time) to exchange mesh credentials.

As some background about the “inistance” to call the assisting device Xenon, I asked Will and he explained that the rationale behind that is that this should be the preferred way to add a node to an already productive mesh network. If you used the gateway as the assistant this would impact all nodes in the network but if you used any other Xenon the impact would be limitted to this one node and all others could still happily communicate with the cloud.

Note, as a practical matter, my IMAC computer has four usb ports. One for keyboard, one for mouse, and two for anything else.

I set up an argon as the gateway, then add a xenon to the mesh, and exit the iphone setup app. Then I unplug the xenon and plug in a second xenon to that usb port, and begin trying to add that xenon using the Argon as the assisting device. This seemed logical to me, and this is what I did. While adding this second xenon, the Argon (assisting device) and the new xenon are both blinking blue (listening mode). Finally, the process comes to a dead end when the iphone app says I am trying to add a device to an existing network (I think that was the particular error, but it may not have been). It suggests you retry or start over. At this point, the Argon (gateway) is stuck in the listening mode, and so the network is hung. The solution…start over with the argon, create a new network and then try adding the xenons one at a time IN THE SAME SESSION using the iphone app. This worked for me, and was the only way I could get it to work. I only have two usb ports to work with, so I had to use the argon (gateway) as the assisting device.
I suppose I could get a usb expander port or power another xenon with a battery and use it as an assisting device, but this is not what I would think a normal person would think.

I hope this helps explain.

This could be one point of failure. Noremally when that happens, you should be able to just reset the Argon which should then get into breathing cyan again and then you just start over with the Xenon that hasn’t finished the process successfully.

At least that would be how it should work - but things don’t always behave as expected :blush:

One possible reason for the Argon geting hung in LM may be that you held the MODE button for more than 10 seconds to enter LM which would erase the WiFi creds (indicated by rapid blue blinking). That would also explain why the process couldn’t finish correctly in the first place.

Or you just use a USB charger to power any additional device.

I am sure others will experience the same issues and you will hear from them as they try to add devices to their existing networks. I was just trying to spare others the frustration. By the time these products are really usable I’m sure this will be straightened out. It already looks like the list of people having problems like this is growing. Until then, if I need to have a larger network, I will just release all devices from their networks (fast blue blinking indication) start a new network with an Argon and add all the devices I need to that network in one setup session with the iphone app. I think that will work. I will try to do this first without unclaiming them first, but if that doesn’t work, I’ll unclaim them if that is what it takes. Thanks again, ScruffR for your perseverance with guys like me.