Add second device to mesh

I successfully added a Boron, and started a mesh with it named fnet.
I unclaimed a previously claimed xenon and tried to add it to the fnet using the iphone app.
Using the iphone add, I connected to the xenon and using the app, identified that it should mesh with fnet. I can’t get it to show up as a device in that network.
How to get it into that network?

I also have problems renaming the Boron. In the iphone app, it keeps reverting to the old name. Frustrating! I’ve renamed it in the console, and many times in the app, but the iphone app regularly reverts it back to the old name.

I guess my question is too dumb to answer. Fourteen people have viewed it, but none have commented. I am an old guy, but new to this stuff. When I go to the console to add my xenon to the mesh it only takes me to install a new device. If I unclaim, then re-install the device, the iphone app asks me which network to connect to, and I told it to connect to the fnet, but it does not. What am I not seeing?

I don’t know if this will help, but I have changed xenons from one mesh to the next with just the IOS app. I haven’t messed with the networks in the console at all.
When I’ve done this, I have not unclaimed, but just hit the ‘+’ button on the app and started over. It asks if you want to leave the old network if it was on one. It also remembers the name, but you can overwrite it if you want.
I’ve added more xenons to several mesh networks in this fashion.
Fingers crossed!


In my experience unclaiming the Xenon is not necessary. Just now I had one on (let’s call it) meshA, and I activated an Argon, set up meshB on that, and then did the “do you want to add a device?” thing. I then scanned the Xenon and the app said “Leave current network?” to which I said Affirmative, Sir. The Xenon is now on meshB.

I have never experienced any issues in renaming or a name reverting back to the previous one. But, I always do renaming in the Console, and also I don’t do it very much.

BTW I always start from the mobile app to add a device. Doing anything in the Console is unnecessary.

I don’t know why you’re experiencing what you are, but I say simplify and use the mobile app for everything in terms of activating devices, creating meshes, and adding endpoints to them.

Oh one other thing – as a test, I just renamed the Xenon I mentioned above in the Console, and then went to the mobile app. If you don’t exit the app after a rename happens, you have to swipe down on the device list to refresh it. Works fine, at least for me.

There is what I’ll call a minor bug in the iOS app that I just noticed – if I rename a device in the app and then go back to the device list, it doesn’t refresh and the old name is still shown. But swiping down does reveal the new name.

1 Like

Hi ParticleD,
Well, I just got the boron and xenon on the same mesh after many tries. I’m not absolutely sure what was the issue, but for one thing, I was trying to pair the xenon with the boron with the internet cable connected to the featherwing that the xenon was plugged into, and I was also selecting to pair it with the ethernet cable connected. After I stopped using the internet, and keeping the ethernet cable disconnected, things seemed to move along and I started seeing the questions that you mentioned in your posts show up in the app. Before, I never saw some of the questions you asked. I may also not have been waiting long enough for the next step to happen.
I think after the app shows the big green check and says something like ‘you have successfully paired…" it would be good if it also said, "now let us begin to set up the mesh’ or something like that. I don’t think I always waited for the next step.
Anyhow, I think the main issue was that I was pairing through the ethernet cable. I’m not sure.
Thanks for the help.

1 Like

If you had the Ethernet checkbox checked on your Xenon, you can’t join another mesh network since currently only single-gateway meshes are supported and having that checkbox checked makes that device the one-and-only gateway in the network and no other gateway (e.g. your Boron) would be allowed on it and vice versa (Xenon+Ethernet can’t join the Boron’s mesh) - for the time being.

Thank you, Scruffr,

Please pass this along to the phone app people. They should put a comment or warning in the app for new people like me who are starting out and don’t quite understand what is happening yet. It will save a lot of frustration and also requests for help. At Particle Spectra conference we used the featherwing and ethernet cable to pair, so this is how I started here. Thanks for confirming why I was unable to set up my xenon in another network.