Unable to add Xenon to new mesh with Argon or Boron w/ OS 1.4.2

Having zero success adding Xenon to mesh.
Successfully setup new Borons (LTE US) and an Argon but cannot add any Xenon (I have 2) after the umteenth try.

All Boron, Argon, and Xenon devices were brand new
Flashed all the devices many times with Tinker and OS 1.4.2 (both via Workbench Flash app/OS and CLI particle update)
All devices factory reset (mode + reset, release reset, wait until white)
The Boron and Argon devices show up in my console and I can interact with Tinker
Tried with Boron or Argon as gateway. Deleted and recreated many mesh networks. Was able to add my second Boron as a node to a mesh but never the Xenon.
Tried Particle app on IPhone and IPads running IOS 13.1.3 and Particle app version 3.0.2

In the app I scan the Xenon (blue learn) and then Boron or Argon as assisting device.
Entered the password for the mesh network and moves on to the final screen:

  1. Your Xenon is joining the xxx mesh network
  2. Request permission from assisting device to add Xenon
  3. Adding Xenon to the mesh network
    4) Starting a secure session with the Particle Device Cloud via gateway << Stops Here

At this point after about 30 seconds there is a popup in the app
“Error - Your device could not connect to Device Cloud. Please try again”
I have hit retry a hundred times and no change.

Argon or the Boron as the gateway at this point are breathing cyan.
The Xenon is cycling between rapid and fast cyan with an occasional yellow/red every minute or so.

Oh, and I have tried several wifi networks with the same behavior (the old IPv6 issue) on the Argon and been to three cities (all AT&T) with the Borons and same result. Never can I get past the Error when the Xenon tries to connect to the Device Cloud.

Any ideas to debug or an issue in the latest code?

If you really had your Boron join a preexisting mesh it may have lost its gateway capability as multi-gateway networks (aka HA or High Availability mesh network is a not yet released feature). Hence I’d remove that Boron from the network to avoid potential adverse effects “semi-baked feature stubs” that may (hypothetically) be present in the device OS already.

Was the Boron/Argon also blining blue at this time?

This would suggest a keys issue.
You could try putting your Xenon in DFU Mode (blinking yellow) and try the following commands

particle keys doctor <yourXenonsDeviceID>
particle keys server

Also, does your Xenon show of in any of the registered networks in console.particle.io/mesh?
Can you try adding the device via CLI (particle mesh add ...)?

1 Like

Thanks!
It was definitely the keys on the Xenon. Ran both commands and they started breathing blue.
Because the setup in the app did not complete I did not see the nodes in the console but the device count went up?
I ended up running setup again and adding them to an existing network (with a single Boron as GW)
Success!

To answer your other questions:

I only used a second Boron as a node to see if it was a network issue with the Boron or Argon gateway or just a Xenon issue. Most testing was done with a single gateway on the network until HA mode is supported (please please please soon!)

When the Boron or Argon was the assisting device, yes it was blue and then went off learning mode as I proceeded thru the setup and it went back to breathing cyan.

Any idea why the keys would be wiped? During an OS upgrade or maybe the factory reset I did? Just want to understand how those are wiped or become invalid. Out of the box it never worked so maybe an issue from the factory?

1 Like

I just want to make sure that everyone is aware that you can use the Particle CLI to set up/manage meshes, without needing to scan any barcodes, connect via BLE, etc. The only caveat is that any devices that you’re configuring need to be connected to the computer that’s running CLI (e.g. if you have a gateway device and want to add a repeater/endpoint node, both have to be connected via USB.)

Do a particle help mesh to see all of the available commands.

1 Like

Yes this seems to be a great tool so thank you guys for building it into the mesh platform!
Would be good to have an order of operations or CLI based mesh setup guide versus just a list of commands. Apps are great but to script large field deployments will require a CLI.

Sim, Sim, Sala-bim. So it is written, so it shall be done. https://docs.particle.io/support/particle-devices-faq/mesh-setup-over-usb/

1 Like