Having trouble adding Xenons to mesh network

Hello! I’m trying to create a mesh network with 2 Xenons and an Argon. These are all running firmware rc27. I’ve tried multiple ways and have been unable to get this to work. Here are my steps:

Setup is USB-3 hub with 4 ports plugged into Macbook Pro USB-A. Android phone (Pixel One).

  1. Reset Argon & Xenons completely (hold down until fast flashing dark blue then start in listening mode)
  2. Deleted and reinstalled Particle app (v 2.3.11) on Android
  3. Pair Argon with phone and connect to mesh/ device cloud: SUCCESS
  4. Device name: mouth66, network name: wedding, network password: wedding: SUCCESS
  5. App says: Set up next device (Xenon #1)
  6. App says: Pair device with your phone
  7. App says: scan sticker, pairing with Xenon: SUCCESS
  8. Your Xenon is scanning for mesh networks to join
  9. Your Xenon is joining the mesh network
  10. Requesting permission, Adding Xenon… and it hangs on the starting a secure session with the Particle Device Cloud via Gateway

Finally: Setup has encountered an error and cannot continue. Please exit setup and try again.

Occasionally there is a deviation from the above where the app asks for an assisting device, but then times out. This doesn’t happen every time, and I’m not sure what I’m doing differently to get this request.

Thoughts? and thank you!

If you set up the gateway device (Argon) and then immediately add your Xenons to the mesh, it should not ask you for an assisting device. But if you exit the app and then set up a Xenon, you will have to scan the Argon’s barcode and put it into Listening mode so that it can do the Assist.

(I don’t think this has anything to do with your particular issue, but just note that for the time being, always use the gateway device as the Assister. You are supposed to be able to use any other device that’s on the mesh to Assist, but that’s not working right now (or at least it hasn’t for me). It always gives a "wrong password"

I don’t know why you’re encountering that issue; since the Argon is connected to the cloud mesh setup should “just work”. Now, there is one bug that’s fixed (see below) that I suppose could cause that to happen; the Argon will act like it’s online (breathing cyan) but is not. Several people have encountered that, and if the issue were to happen while adding endpoint devices to the mesh, it would fail like that.

I’ve said this a few times today already, but Device 0.9.0 is imminent (hopefully tomorrow), and it has a number of fixes for the Gen3 devices. Once that’s released, set up your entire network again with the mobile app (which will automatically update the devices to that version) and see if things improve.

1 Like

OK thanks. Guess I’ll wait for the new firmware to see if that will help.

0.9.0 is live!


How do I get the firmware onto the Xenon?
With the CLI, I get the message: There are currently no system firmware updates available for this device.

With the build.io, I can’t see where to flash the firmware.

Check for a new CLI installer. I don’t have the means to check myself at the moment.

I am assuming you have updated your Argon to 0.9.0 – you’d want to do that first, to get rid of the pesky bug I mentioned above (which could possibly interfere with you getting your Xenons set up).

If you’ve done that, can you try setting up the Xenons again? (Make sure you have the latest version of the mobile app – 2.3.11.)

If that doesn’t work—

If your Xenons were on-line and happy, the next time you flashed user firmware (“app”) to the devices, it would update Device OS to what you have displayed in your screenshot – in this case, 0.9.0. But if they’re not, you’ll have to use CLI to flash 0.9.0 to them.

I don’t think that particle update works with the Gen3 devices yet. See my instructions in this post about flashing Device OS, Tinker, and the bootloader (in that order) to the devices, but of course replace the “argon” in the file names/command lines with “xenon”.

I just updated my CLI to 1.39.0 – it still doesn’t support particle update for Gen3 devices.

Just if the previous responses to your question don’t point it out explicitly enough:
When you OTA flash a new application that requires a device OS update there is a feature called Safe Mode Healer that will kick in and resolve the issue for you and make sure the device OS is updated automatically (providing you have a stable cloud connection tho’ :wink: ).

You can tell whether SMH kicks in when you see multiple magenta/reset cycles. If that happens you should leave your device alone till that stabilises again (up to 5 minutes worst case).

I have the latest CLI, and the dfu-util, so I tried the firmware update that way.
New firmware is here for anyone looking for it!

I was able to upload the new firmware to the Xenons but the Argon bricked after the update.
There’s a thread about resetting the bootloader to fix bricked modules, but I lack the Segger tool to get at the nRF.

I have a new Argon on the way. :slight_smile:

@ParticleD I just read your thread about flashing the firmware. Thanks, I wish I’d seen that yesterday :wink:

There’s a difference between what you suggest and what is listed in the docs.
The docs suggest to use the hybrid.bin files and flash in one step. You suggest to use the system+tinker+bootloader files in a few steps. Is the end result the same? Can you confirm?

What does your Argon do?

The Argon is dead. The yellow light near the USB port blinks a little when I wiggle the USB, but otherwise I can’t get any other lights to go on and stay on. I’ve changed both the cable and the USB port. The CLI can’t find it either.

The hybrid bin file is what’s recommended to update factory-fresh devices (which are currently being loaded with rc.11 or something like that), because (at least for now) the factory firmware is “monolithic” and the hybrid Device OS can update over the monolithic image via OTA (system-part1 cannot). For a device that’s already been updated to at least 0.8.0-rc.25, the system-part1/Tinker combination is probably best. I’m not sure why the docs mention the hybrid version, since that section concerns DFU mode and not flashing OTA.

FYI when the hybrid version is flashed, Tinker will come along for the ride, but only if the user firmware space is empty.

1 Like

UPdate: received a new Argon, and the Xenons connected just fine. Guess I just got a bad part.

1 Like