Unable to setup Argon on Mesh network

Two days ago, my programmer (senior software engineer) and I had no problems setting up pairs of Argons and xenons. Today we have been working for hours trying to setup an Argon and a Xenon on a new mesh. It has been a nightmare. We are trying to setup an Argon on a new mesh network that was working fine yesterday on a different network, a different account. Today, in both the iphone setup and the android setup process, while we are trying to create the mesh, we get an error, and the Argon goes into a rather extensive red flashing status indicator, says we lost the bluetooth connection and cannot get past setting up the mesh network. We have success setting up for the wifi, but not joining the Argon to a mesh network.

What Device OS version is on the two devices you’re having troubles with?

1 Like

And that error would be?

And that indicator would be?

Are you setting up a new Mesh network with the argon as a gateway? Currently, that's the only role an argon can fulfill within an existing network, and only one gateway can be used at this time.

When posting in troubleshooting, try to include as much information as you possibly can. You can't post too much, but everything you keep behind that you might not think is worthwhile posting could have a clue towards the issue.

1 Like

The reason I posted such a general description is that I was wondering if something in the Particle mesh system had changed overnight. We will try to sort things out and give more data as we troubleshoot. We also had a xenon with a bad sticker on it, which confused us for a while. The Particle android app would not read the sticker but the iphone setup app would. Set that xenon aside and got passed setup with another.

Hey Tom,

As there are many variables, it’s not always easy for us to pinpoint. So we can never have too much info. :smile_cat:

If you are able to provide more info, that would be immensely helpful. Do note that in our recent versions of Android and iOS, we have debug logs available! If you happen to reproduce, feel free to post those here or in a support ticket. This would be immensely helpful in helping us figure out what went wrong.

1 Like

Thank you, Mstanley and others. Our software engineer did not want me to post before we had more data, but the setup is so dramatically problematic for me today that I figured something else must be going on. We will work on it more this afternoon.

Question: How do you delete a mesh once it is set up. We removed all the devices, but it still stayed logged in the console. We tried to start over a couple of times. Each time, we found we would have to try using a new name for the mesh. We don’t see a way to delete a mesh.


@TomEldredge, removing ALL devices, including the gateway, and unclaim them. Then, set them up again using the mobile app. They won’t need to be claimed and the setup should be faster.

We also had the red flashing issues. I think we were having the 10 SOS Red status LED also, as were others. However, I had not identified the specific sequence of the red flashes. We added the waituntil mesh ready line in setup and this eliminated one of our setup problems. The code worked fine the other day. Now, with RC27, it did not.

1 Like

I assume you found this thread with a similar SOS 10 issue and a solution of adding waitUntil(Mesh.ready). Cross-linking for reference:

1 Like

Yes, ninjatill, that is how we solved the problem with setting up our mesh network. Every time we set up a mesh and loaded our code into it, it would hang up the argon, and we could not get anything to work after that. So, we would try to set it up again. This problem was coupled with the problem that we could not read the sticker on the xenon with the android that we tried to use. We had done all our previous setup with an iphone.
It was because of the change in RC27. Every thing worked the other day, and I could not imagine that a Particle xenon sticker could have a problem. Especially when the iphone could read it. Now that mesh is working with the waitFor(Mesh.ready()) command and a xenon with a good QR code sticker.

Not sure if you are using waitFor() with the correct syntax tho'

You pass the function pointer to wait for, not the return value of that function (and a timeout parameter).


My fault… I should have copied and pasted. Thanks for the explanation. I understand the difference now. I corrected my quote above.


We have noticed some issues with Android devices reading stickers on occasion. We are still investigating the issue.

If need be, you could try submitting a support ticket, providing a picture of the sticker and it’s S/N below. We can generate you a new digital one on our end and see if that scans any better