Cannot setup Xenon using Android app (v2.3.11)

xenon
Tags: #<Tag:0x00007fe21d735210>

#1

I’ve had a small mesh network setup for a few months now, and after some of the issues early on it seems that everything has mostly settled down. However, I’m now having trouble re-setting up one of the Xenons to join the network.

Trying to pair to the Xenon through the Android app never completes for some reason. As far as I’m aware there’s not an option to set the device up through particle-cli, otherwise I would have done that.

The Xenon is blinking blue, and running Device OS 1.1.0. My phone is a Pixel 2 on Android 9, running x2.3.11 of the Particle app (although I’ve also tried with an old tablet, also on Android 9, without luck).

I’ve tried uninstalling and re-installing the app, enabling location, reflashing the Xenon firmware, and a number of other things, but I can’t see what I’m missing here. Any advice would be appreciated!


#2

Having same problems…Argon as gateway, I can get a brand new xenon to pair but none of my existing xenon’s will pair and complete.


#3

There is particle mesh --help

Which device are you using as assisting device?
Is the assisting device also blinking blue and have you scanned its data matrix?


#4

Not sure how I managed to overlook this, thanks! I’m at work right now, but I’ll give it a shot when I get home.

I’d not managed to get far enough to select the assisting device in the setup flow, unfortunately - just pairing with the “new” device.


#5

Well, that was easier than I’d anticipated! For anyone who sees this in the future, this does the trick:

particle mesh add <new device id> <assisting device id>

You have to have both devices connected via USB (which it doesn’t mention in the documentation), but that’s not too much of an issue.

Also, I was running into a LIBUSB_ERROR_NOT_FOUND error on my laptop for some reason. Carrying on using my desktop sorted it out though.