Xenon blinking blue permanently

Hello
I have completed the setup of my Xenon with a smartphone. I have also created a mesh network using as assisting device an Argon. During the Xenon setup, I can see on the smartphone a success message. Then I proceed in the pairing with Argon using the mesh network I have created. The pairing fails. The Xenon is permanently blinking blue. I’ve checked the Bluetooth connectivity with the phone, the Xenon is presented but denies to connect with the phone. Using the CLI, the only that I can retrieve is the Xenon ID number. Nothing else is applicable (either setup, doctor, dfu etc. etc.)
Thanks for any help.

IIRC, particle setup is not meant to work with Gen3 devices.
For particle flash --usb ... (and other features) you need to put the device into DFU Mode (blinking yellow).
You can also try particle mesh add ... (also in DFU Mode) to assign your device to your mesh.

Hi ScruffR
Thank you so much for the reply.
My issue is that I can’t give a name in my Xenon, I tried everything and rejected.
Thanks

Once you got your device claimed you can name it via CLI or Web IDE - your device doesn’t even need to be online for that as the device name is only stored in the cloud and not on the device itself.

Do you see the Xenon in your Web IDE device list or via CLI particle list?

Thanks
OK, I understand. I thought the same. It looks like to be the same problem that I had with Argon. My technical director bought and shipped to me an Argon and a Xenon one year ago. Two days ago, I first tried to claim the Argon with CLI and had failed. I don’t remember which command I used (I think “particle keys”??) and received the message that “this Argon belongs to someone else”, etc. Then I requested to transfer the Argon in my account, and after 1 day I received from Particle an email with approval and a name for Argon. I will try to repeat this process with Xenon.
BTW, the Argon is in a healthy state but I can’t flash new code permanently. The Argon had flashed with an old firmware one year ago. The new firmware is successfully compiled and flashed with Web IDE, it runs for a while, and then the Argon resets to the old firmware. I can see some commands of it published on the Console. Is there a way to erase permanently the old firmware?
Thanks.

This suggests that the Argon was part of a product. It has to be released from that product too - not only the owner of the device.

You need to get back at Particle again for that too.

OK, thanks. In which way? Do you mean that I should request technical support?

Yup, a support ticket would be good.

Just now I tried with CLI the “usb list” command. It returns exactly:

no name [e00fce6895526a9db0fe5465] (Xenon, LISTENING)

Thanks, I try to open the link but… doesn’t open!

OK, no problem. I did it… manually!

Thanks.
Back again to Xenon. Any idea?

So your Xenon is claimed and since - as I said - it doesn’t need to be online to be named you can just carry on with

particle device rename e00fce6895526a9db0fe5465 MyXenon

Thanks.
I tried (with CLI) but returns:
failed to rename e00fce6895526a9db0fe5465: Permission Denied
Xenon module is still in listening mode.

Renaming the device and Listening Mode are two separate issues.
Which one do you want addressed?
You said

So that’s what I’m focusing on for now.

Are you sure you were executing particle list and particle device rename on the same account?
Is the device ID you got from particle list exactly that one you are using with particle device rename?
Or have you already got a Xenon with the same name?

You can also try Web IDE to rename the device.

Yes, I use only my personal account.
No, that Xenon does not appear on the particle list.
I can get its ID only with “particle.identify”.
No, I have only one Xenon.
I will try with Web IDE and let you know.
Thanks a lot

If the device isn’t claimed to your account you cannot rename it either way.
You can try the mobile app again and create a new mesh on the Argon and then add teh Xenon to that mesh in the same process.

Alternatively you should be able to claim it via CLI when your Argon can connect to the cloud and both devices can be connected to the same computer via USB simultaneously.

BTW, do you see a mesh network in console.particle.io/networks

I tried what you suggest.
I see in console the network I created, it shows:
Name: fotishome
Total Device Count: 1
Gateway count: 0
Network type: Micro network (wi-fi)
OK, to make the thing short I tried everything you could think in the last 2 days. The result is the same, the Xenon returns always in Listening mode (blink blue).
I think is a similar issue that I had with Argon?
It would be better to ask again a ticket for technical support?
P.S. I have also the problem of the new member 20 replies max. I should wait for 20 mins to post my reply.

You are now “Basic User” and that limit should not apply anymore.

You can ammend your Xenon issues to the Argon ticket you already opened.

Another possibility might be to record a fresh attempt of a completely new mesh setup for Argon and Xenon and upload that to something like YouTube and post a link here.
Maybe we can see where things go wrong then.

Thanks a lot for your time,
I think this Xenon could be assigned in my technical director (who is very busy) account.
There is not other explanation! Everything I try (e.g. rename device) it returns “Access Denied”.
I think will ask technical support again.
BTW, the Argon is working flawlessly now and I can flash my code successfully. But only with Web IDE.
I can’t flash with Particle Workbench, either Localy or Cloud. The terminal returns the message “no device detected”.
Thanks a lot again.
I will be back within 1 hour, its time for my daily walk