Xenon - Argon connect stuck at "Adding Xenon to the mesh network"


#1

I have an Argon as gateway to wifi and successfully connected a couple of Xenon devices. I have since done a reset of one of the Xenon devices (Hold mode button down until led is flashing blue). Using the app to reconnect, it will no longer go all the way through the mesh connection process and stops with “Adding Xenon to the mesh network” in bold.

Any suggestions?

Devices all at 0.8.0-rc25.
Phone used to activate: Moto C plus; android 7.0
Particle App: 2.3.7


#2

I had the same issue after the Part 1 downloaded completed. The Particle Star logo kept spinning in a screen with nothing else except a X close. Finally after 20 minutes, I clicked on the X and App took me to finish the connection to my Argon Gateway. I did check to find out my Android App had an update which I downloaded. I plan on adding another Xenon to the Mesh network today to see if the issue was fixed.


#3

Good point ion the particle app. I downloaded a new version today and it made no difference. I’ve added the version of the app to the original post for completeness.


#4

I had a similar issue - hard power cycling (removing USB power and restoring it) a couple of times while the Adding Xenon to Mesh Network was happening solved the issue.


#5

I have succeeded in getting the difficult Xenon to connect occasionally. Using Particle-CLI I reflashed the system firmware and also flashed tinker as I suspected the user code I had on the device was at least part of the problem.

Two full system resets later I got to a point where the Xenon would flash cyan and then give a red pulse every 15 seconds or so. I tried a couple more times with the same behaviour so I left it and some time later it connected.

I powered it off and on a couple of times and it reconnected but 30 minutes later it was back to cyan flashing then a red blink. A second device now shows the same behaviour.

And 15 minutes later… They’re both back to working again.


#6

I believe this should be fixed by the rc26 firmware. Try updating your mesh devices to rc26 and try again.

Let us know how it goes!


#7

I have run through 4 Xenon connections to a mesh with an Argon as helper with no problems at rc26.
I’m not sure what the original problem was but I have not seen it since.


#8

I’m having the same problem. There doesn’t seem to be a lot of people talking about it anymore. What did you end up doing to fix it?


#9

I’m try and having the same issue as well. App updated the Xenon, getting stuck at that same screen whey trying to join the mesh network, which it finds fine, then asks me to scan code again, then stuck!! :frowning:


#10

It doesn’t ask you to scan the code again but it asks you to scan the code of an assisting device.

The best option for your assisting device is usually the gateway itself, which you’d need to put back into blinking blue mode and then scan the code of the gateway.

I know that’s not immediately obvious, but when you watch the whole GIF and read all the blurb in the image you should get the picture.


#11

its extremely confusing as they say assisting Xenon… I don’ have another Xenon, so finally clued into the “assisting” portion and did the Argon. Should Say assisting device (Xenon, or Gateway Argon/Boron).
Thanks for the response!


#12

Yes, that’s something I have been “ranting” about several times already behind the scene and then filed this issue a while ago

So far it went unheard, everybody who can chime in on that issue is welcome :wink:


#13

It is particularly confusing as the App (current version as of today) no longer has the message down the bottom that says “ASSISTING DEVICE BLINKING BLUE” [Ed - caps in original] as is shown in this Youtube video: