Xenon Mesh Connection Issues

I just got my Argon and 3 x Xenons and am having some issues. Let me lay out my setup:

  • Ubiquity APs with shared SSID names across 2.4ghz and 5ghz bands.
  • SSID Names have no special characters (only letters and numbers)
  • WAN Password is only letters and numbers.
  • Boards deployed in pairs on large prototyping bread boards with plugged in power supply.
  • Android Pixel phone

Starting with the Argon, it was a rough ride setting it up out of the box. My problems were solved when I flashed it with the hybrid-0.8.0-rc.25-argon.bin.

I next started configuring the Xenons 1 by 1. First one worked like a charm. Second one hung up after giving it the mesh password. It turned out it joined ok but did not assign the name to the Xenon. I fixed this via the device manager on the Particle site. 3rd one worked just fine.

I had all four lit up in a stable mesh network. I decided to do a power off/on test. After I did so everybody came back up and 1 xenon did not join the mesh network to completion. It was stuck flashing in rapid light blue (Connecting to Cloud). I began to suspect it was a troubled chip but after some playing around, it seemed like the last chip connecting to the mesh would get hung up. After turning some Xenons on and off, I eventually got all of them to connect.

So if I have Xenons 1, 2 and 3. #3 is stuck rapid light blue flashing. I would cycle its power and the same result. I would power down #2 and recycle #3. #3 would then connect up just fine. Power on #2 and it would stop at rapid flashing light blue. Recycled power to #2 a few more times and it eventually got connected.

Getting ready to write some code to play with the mesh now that I have a workable way to get things all connected. Wanted to advise of my experience and see if there were any suggestions.

You need to wait for firmware RC26 to see if that fixes the connectivity and reliability issues.

Thursday I started to set up an Argon as a Gateway using the Android App. It went thru Part 1 and Part 2 of the download and then to a screen with just the Particle Star spinning the the middle. I waited for 20 minutes with no change, so I hit the X exit and then the selection screen came up to create the Mesh network.
Today I started adding an Xenon. This time it had only a Part 1 download, but again the screen with the spinning Particle Star. Again I waited a long time and X ed. to find the Mesh Network selection screen.
Just seems to me, once the downloads are complete you should open up the selection screen.

Same issues for me. Have to repeat the process many times on the Adroid app too get post the firmware upgrade completion. Should be worked out in days or weeks to come.

Great. Will be anxiously awaiting its release.