Unable to set up devices using particle app

I’m trying for the 4151451th time to set up a basic application and network with the new gen devices but I’m this close to give up…

I have all of the new board types but this time I wish to setup a mesh network between two xenons and one boron.
I tried setting the boron and it’s completing the setup and connecting as long as i don’t add any devices.
I then tried to add one xenon through setup but it just hangs on the screen “Your Xenon is joining the mesh network” in step 2: Adding Xenon to the mesh network.
The Xenon’s LED lights cosntant white and just hangs.
If I try to exit the setup I need to go through all of it again (just to fail again).
It also fails with a different xenon.
The devices are updated via the phone to 0.9.0.
The most annoying part is that I have absolutely no idea what goes bad in the process.
Could anyone help please?

Have you put the Boron back into blinking blue and then scanned its data matrix when you were asked for an assisting devices?
Are you using the Android or the iOS app?

Hi, I did put it into blinking blue state and then scanned.
I tried it again now with another xenon, I got the devices to be both breathing cyan but the app jangs in the exact same state.
I’m using Xiaomi Mi A2 running android 9

Update, I tried to connect another xenon to the network. I did the same process and now the devices are: 1. boron is breathing cyan, 2. former xenon is breathing cyan, 3. new xenon is breathing blue (there’s no mention of such state everywhere. 4. App in the phone hangs in the same state (“Your Xenon is joining the mesh network” in step 2: Adding Xenon to the mesh network.)
When I exit the setup I don’t see the new xenon in my devices list nor in the mesh networks in the console.
I’ll try to factory reset this new xenon and will update again…

Breathing blue means the radio module is on but not connected to anything.

I know it’s documented for Photon and Electron, have to check for Xenon tho’ but should mean something similar.

Thanks for the highlight, however, how can we solve this?
Should I open a bug on the App? should I try the setup with another mobile device?