Can't get to step 2 in setup

I’m completely stymied. My Xenons and Argons and Borons just showed up and I can’t connect to any of them. From what I can tell the Xenons need a mesh so I stopped trying to use them and just have my Argon connected.

I tried to pair to it from my Android phone (Moto Droid Turbo 2) and it just spins and doesn’t connect to the Argon. This also happened with my Xenons.

So I connected via USB and used particle flash to upgrade the firmware to -rc-0.25 and it still spins and won’t connect.

There’s a note that I must upgrade ncp to 0.0.5 but there is zero documentation on how to do that. Help? Please don’t just point me to the firmware file - I have that but that’s not documentation.

Any idea why none of these will pair at all?

Also, I’d like to use the Serial debug tinker but can’t find the baud rate for it. I get nothing at any baud rate although it does disconnect at 14,400. Just cycling through baud rates with putty gets old really really fast. Is there some sequence I have to send it?

I had some issues with using just the mobile app at first. I failed to connect an Argon several time. Then I tried to go to the website: After following the prompts there, it gets to a point where it wants you to use the particle mobile app. I switched over to the mobile app and all worked smoothly from there. I would suggest walking through the website first, until it prompts you to go to the mobile app, then switch over. See if that helps.

I gave that a shot. It really doesn’t say much but use your Android app to connect to the board. The Android app just sits there saying “Pairing with your Argon” forever.

I’ve tried rebooting the phone and rebooting the Argon and power cycling it and…? Wish I could get some USB diagnostics.

Do you have another mobile device with Bluetooth to test with? Others have had problems with certain manufactures such as Samsung (mostly newer devices as my Galaxy S6 worked fine.)

I tried using my Android tablet (NVidia Shield) with the exact same result. Unfortunately my wife’s phone is the same as mine. I think I’ve got a Mac-Mini with oldish OSX still on it to try if I have to.

I wish I could do this from desktop Win10.

I think this needs @rickkas7… Or one of the elites @ScruffR, @kennethlimcp, @peekay123, @Moors7?

Well, I was able to get USB to do something. I put std Tinker on it (instead of the debug one) and it supports some commands via USB/Serial (baud rate seems to come after hitting enter a few times). See here:

I was able to do a “w” to set up the wireless manually, but doing a “m” says the mac address is all zeros - and it never gets through the router as far as I can tell. I probably have to update the ncp firmware but don’t know how.