Argon/Xenon - Particle App 2.3.{6,7} Android - Spins during pairing


#1

Trying to get a sense if I’m the only one having a problem pairing during setup.

After the code scans the phone will sit and spin indefinitely at “Pairing with your Argon/Xenon”

I’m using a Nexus 5

Perhaps we can use this thread to catalog the devices that are not working in this specific way. There are other threads for issues during other points in the setup so this one is specific to the device spinning during the pairing phase.


#2

See:

Which happens to be a Nexus device too…


#3

Note 3 also same issue, is there a work around or is this the only way to register devices?


#4

Have you tried updating the app to 2.3.7?


#5

I have the same issue and I am using a OnePlus 5. ;-(


#6

I am having the same issue. I had to restart the sequence a few times for each device.
I am using a Samsung A5 2017 with Xenons and an Argon.

Overall, I stopped trying to create a mesh network. After months of waiting, I feel it was still too early for Particle to ship the 3rd gen devices.

That said, I am confident they will correct the software and firmware issues. Probably we are so much used to get a reliable environnement from Particle, that we are taking it for granted, and I am unexpectedly disappointed.


#7

Same issue with 2.3.7 - topic updated. Not expecting that this will be fixed until the Nexus 6 known issue is fixed.


#8

Using the latest version available on play store.
Is this really the only way to register a device? No other manual way to set them up whos idea was that? Not good enough for a production support senario. Qcode registering is cute but not practicle for hundreds/thousands of devices. Looks like it may be too bleeding edge for companies I may park the devices and look at more mature options for prototyping.
Shame as hardware and concept looked to align with what we are doing.


#9

I’m sure you will be provided a file containing all the device information in a bulk order just like the Gen2 devices today.

As for setting up of devices, acknowledge that having an alternative way to setup the device when BLE fails will be useful, same goes when you mass manufacture.

I’ll check in to see if there’s any development on this method.


Refund for large pile of Mesh devices
#10

I was experiencing something similar on my Motorola Moto g5plus phone… after rebooting my phone it worked more or less like I would have expected (aside from once the device was updated I had to back out of setup and retry).


#11

Chiming in on my experience with claiming both an Argon and a Xenon:

Nexus 6 – Android 7.1.1
Both Argon/Xenon does not work; stuck at the “Pairing with your Argon/Xenon” screen

Nexus 5 – Android 6.0.1
Argon: works, firmware updated to 0.8.0-rc.25, claimed and able to set up a mesh network. I see the device running Tinker in the CLI.

Xenon: barcode scanned, firmware updated to 0.8.0-rc.25
However, when attempting to join the mesh network previously created with the Argon, the screen stays at the “Your Xenon is scanning for mesh networks to join” with the mesh name correctly displayed, there is no further indication that I could do anything else. Tapping the mesh network name brings me to the “Add Xenon to mesh network” screen, but it implies that I need to have a previously-added Xenon to act as the commissioner to allow a new Xenon to be added? But I’m only pairing my first Xenon with the Argon so that’s not possible… long story short, Xenon setup does not work.

Update: this wasn’t clear in the Particle App instruction as it implies to scan the barcode of another Xenon that’s already online. I tried putting the Argon gateway into listening mode and scanning it’s QRcode and now my Xenon is connected.


#12

Yep, I’m also having problems with my Nexus 5X, Android 8.1.0


#13

I also had problems setting up my Argon with a Nexus 5X. The Android app would appear to complete the Device OS update, the Argon would restart and enter the “blue-blinking mode” and the app would hang and spin forever. After three repeated updates (restarting the phone each time), the setup picked up at the step after the Device OS update, and I was able to continue without any additional problems.

From my perspective, it just looked the phone app wasn’t able to get confirmation that the update had completed, or wasn’t able to establish a BT connection following the update. My two Xenons were set up without issue.


#16

Made some progress, I used my sons Samsung S7 and was able to update a Xenon but beucase I had no gateway it could not get past the “Looking for mesh network to join” But when I used the same phone to try and connect Argon I got the normal Spinning Wheel. Too update another Xenon I had to clear the app data cashe first. Also Tried my Daughters Huawei Kii-l22 and it failed also. Just in case it is important the two that always failed both have BT4.0 and the one that worked but just for the Xenon was using BT4.1.


#17

Still having the same issue with v0.8.0-rc.26. Both an argon and xenon were dfu flashed with the new firmware and the devices were not able to pair with a Nexus 5.

I have been able to connect and claim the argon over serial but the device goes back into listening mode after a reset, which requires using serial to set up the wifi creds again.

Even though the device shows up in my list of devices, it’s not possible to set up a new mesh network using console.particle.io because it directs back to the mobile app setup process. This of course is a dead end due to the pairing issue.

Not sure were to go at this point.


#18

Could I ask you to try restarting your phone and seeing if that helps? Android caches certain BLE parameters for a particular device and since we’ve changed them on the device side, you might have to manually invalidate the cache on the phone.


#19

Restarted the phone and the xenon and left it at the pairing screen for a few minutes, no change.


#20

I’ve enabled debug logging in the BLE subsystems and would appreciate if you could flash this binary to your Argon and grab the logging output either from Serial1 (TX @ 115200) or USB Serial while you attempt to connect to it.


#21

I’ll do that shortly. I also grabbed a btsnoop_hci.log when trying to set up the xenon, if it’s of any use I can send it along.


#22

Not getting any output off of USB serial, but the i: command works fine so the serial connection itself is working