Issue adding a Xenon to a mesh network

So, I’ve created a network using an ARGON and a XENON using a wi-fi at work but then I brought the devices home and I couldn’t find a way to switch the wi-fi network and thus couldn’t do the work I needed, so I deleted the network and removed all the devices. I added the ARGON, created a new network and it all fine and dandy. However, when I tried to add the XENON, it adds the XENON but it fails to add it to the new mesh network because it wants an EXISTING mesh node and It won’t add it to the NETWORK in the ARGON without this second device, which I don’t have. Does anyone have any clues on how to proceed?

I did reflash the XENON with the latest flash using the CLI but I still get stuck in the same step. Any help would be really welcome!

Thanks! -Ian

With CLI 1.35.2 you can run particle serial wifi with the Argon in Listening Mode to add a new set of WiFi credentials.
If you don’t have CLI installed (which would be good to have tho’) but with device OS v0.8.0-rc.25 (or later) you can now use a mere serial terminal to send w to the Argon in Listening Mode which will also allow you to set WiFi creds.

Thanks @ScruffR for the tip. Yeah, I have the CLI installed, that’s how I flashed the XENON with the latest software. I’ll give it try later today since I’m at work again today. That would definitely be handy!! Thanks so much!
However, my original problem still remains, I’m still looking for a way to add the XENON to the newly created network since the old want I had to erase, and as I said, my main problem right now is that the current process requires an existing node in the network as an auxiliary node in order to add a new node in the network, I don’t know why that is necessary. The first time I added that XENON to the network at work it didn’t require an auxiliary node.

So, if anyone knows how to do this, I’ll appreciate some help. Thanks guys!

Eh? The gateway (Argon for you) can be the assisting device to add your xenon.

1 Like

Thanks, @kennethlimcp, you are right, I guess I was not interpreting the “light blue” flickering in the LED as the right signal for the pairing and it kept failing. But after talking with a friend he helped me realized that I needed to hold the mode button longer to get in the right “blue” flickering and thus allow the pairing to happen correctly. So, the issue has been solved. Thanks to all for the comments and for your willingness to help!

2 Likes