Boron can't create mesh network

I’ve been trying to set up a mesh network with a Boron and one/some Xenon’s. In the IOS app, I can get all the way to the end of setting up a mesh network, I name the boron and the network.

The loading screen completes the action "registering the mesh network with Particle Device Cloud."
The next line that is in the progress is “boron-01 creating the mesh network locally,” and this is as far as I get.
When I go into the console, I can see the mesh network I tried to create when I click on the boron, but when I click on the name of the network, I get an error.

Looking for some insight as to why I can’t create the network/how to move forward. I have tried unclaiming the Boron and going through setup many times. While I’m doing this, the light on the Boron is slow blinking cyan. I’m using the regular sim that came with the Boron, and have my card on my account and authorize it to charge for the plan.

Edit: I have also tried putting it in listening mode while it says it’s creating the mesh network locally, and can’t get the device to into listening mode. I have also tried using the CLI, no help at all.

Have you managed to activate the Boron’s SIM card?

BTW there’s normally no need to unclaim a device for troubleshooting purposes.

@melbatoast let us know if you were able to activate the SIM card and how we can help you!