Catch 22 setting up 3rd gen devices

I’m just setting up my Argon and Xenon boards for the first time today. Setup of the Argon went just as smooth as I have come to expect from Particle, but the Xenon’s do not seem possible to setup at all?

I set up my Argon as a Gateway. During setup, it self-updated via my Huawei P10 Pro phone at a less than impressive speed. It took like 15 minutes to update the device? Next was the Xenon. It too updated, but only after 3 failed attempts connecting to the device. Then I get to the Mesh setup, I select my mesh network and then I’m asked to scan an assistive device already on the network. I have no devices on the network - that’s why I’m setting up one? So setting up a device is not possible unless you already have a device setup and since this requires a device to be setup it is not possible to do at all. Very much a Catch 22?

Despite the less then clever wording in the app, there MUST be a way to do this so I’ve tried scanning both the Xenon I’m setting up and the Argon that is my Gateway. In both cases this just causes the Particle app to hang while it says “Pairing with your Xenon”. I follow the instructions in the app regarding pressing setup and such, but to no vain.

Given how many months it’s been since the release of these devices, I assume that many have them up and running. What am I doing wrong here and why is it so poorly explained in the app?

Well, you just told us:

That Argon is your “device already on the network”, since it’s the one creating the network in the first place. A gateway should be the one creating the network, and you can add devices from there on out.
You should be able to scan the Argon during the setup process, and go from there.

Updating them to the latest version using the CLI is also an option (that’s considerably quicker than the app). There are also some new Mesh commands available (in Beta):
Mesh and USB commands in the CLI

1 Like

Thanks @Moors7. They really should fix the wording in the app on this.

Scanning my Argon gateway still instructs me to put this in Setup mode, but won’t that turn off the Mesh Network that I’m trying to connect to? I’ve tried the instructions and nothing ever happens. The app just says “Pairing with your Xenon” and both boards blink blue. One would assume that it knew that its trying to contact an Argon and not a Xenon? Anyway, Waiting for 15 minutes has no effect, but this should work within just seconds, right?

Been there already :wink:

It would for all other devices that would be on that network already. That’s why Particle has originally avoided to mention the gateway as assisting device (not anticipating the confusion that created tho’).

So you put the Argon into Listening Mode and then scanned the Argon’s data matrix to tell the app that it shall be used as assisting device?

1 Like

Yes. It still just hangs on the Xenon/app. Nothing moves on from there.

I just went through this myself, and I agree that it’s a bit confusing. I went through it at least 5 times and was about to open a ticket before I watched the video and realized that I needed to press the button on (and scan) the gateway device, not the Xenon that I was adding.

I realize now that the instructions say to do that on a device which is already part of the mesh network. But that point it says something like “registering with the Xenon” (I’m going from memory on that last part, so I could be mistaken, but that’s part of what made me think I needed to scan the new Xenon, rather than the existing Boron.)