Mesh System firmware update difficulty

Hi all,

I am trying to flash new code to a Xenon that I got at Spectra, and am having trouble.
Using the web IDE, I select default firmware, which is an -rc23, while my firmware is -rc15.
It seems to flash OK, I get the success message, but then when the xenon restarts after getting the new firmware, it flashes an SOS and reverts back to the previous code.

On this version it’s very hit or miss to get a cloud connection thru mesh, and I’d be very interested to try out the newer changes.

Can anyone help me get this on a newer version?


Can you bump to RC24 and update your xenon again?

rc24, very exciting! I’m traveling for the next week, and can’t get to the xenons physically.
I’ve just reflashed and from the console things appear right, but the xenons don’t show the system firmware version in the console or in the IDE - is there a way to tell what Firmware is on a device from the CLI?

EDIT - I think it worked. I put the partibadge firmware on one unit, and could see the functions and change name, etc - then I flashed tinker with rc24, and after the flash the badge functions are gone and the tinker functions are there. Previously when I tried to flash, it would revert back to the previously installed firmware.

I’ll keep an eye on it from the road and see how well they keep talking to each other while I’m gone.

1 Like

@kennethlimcp, FYI

Well, I was able to get rc24 on these units, but they did not stay live very long. They all dropped offline within 36hours, including the gateway that was connected via ethernet.
The gateway, however, kept breathing cyan, even though it became unresponsive to pings and to signaling from the IOS app or web IDE.

I was able to reconnect the endpoints by rebooting everything with the gateway disconnected from the ethernet, and when they were all flashing fast green, reconnecting the ethernet. You could ping, flash, etc.

I re-added the gateway and then the endpoints which then updated them to RC-25, but once I’ve done that, I cannot get any of the endpoints to connect to the particle cloud. Fast green flash is the best I can get. So I can use a unit that is on the Ethernet shield, but no joy with any mesh functions at all since I put rc25 on these Xenons. I have a ticket in the system which is being worked on by Dave, but there hasn’t been any progress in the past week.

Dave said that this is a problem with units that were updated since Spectra, but that this issue isn’t showing up on the factory fresh ones. Hoping for some way to get them working again before long.


1 Like