Xenon flashing green and not connecting on Serial

My mesh is one Boron and 2 xenons.

The Boron is working fine and is breathing Cyan and responding to my code.

The two xenons are flashing green and I can’t see Serial on them.

  1. I have tried to put the hybrid rc 26 version on one of them. I have Serial.begin on my own program that I flash.

Any thoughts on how I can further debug this?

Ping @avtolstoy.

Hey there @fundamol - do the devices connect to the Cloud when running rc.26 and the out-of-box “Tinker” firmware? It would be good to check that first to rule out network connectivity issues.

If they are stable running Tinker than the issue may be with your code. Can you try upgrading all devices to rc.26 running Tinker and let us know whether your Xenons are still unable to connect?

@will The boron connects to the Cloud. The Xenons obviously do not. I have made my code the simple loop to only print on serial and delay for a 1 second. I have also tried flashing the rc. 26 hybrid firmware and the tinker firmware, but it keeps blinking fast green.

You could put your Serial.begin() call in STARTUP() and also use SYSTEM_THREAD(ENABLED).
In default SYSTEM_MODE(AUTOMATIC) your own code won’t run till the connection got established. Both suggestions above should help circumvent that problem.

BTW, I’d just flash system-part1-0.8.0-rc.26-xenon.bin and your own application FW (or tinker) separately instead of hybrid.

1 Like

A bit of rest and some patience solved it for me. The key was resetting everything and flashing Tinker on all of them to get through the setup process. Now they are all breathing cyan and connected to the cloud.

5 Likes

That’s great news! I’m sorry you had to spin your wheels to get it working in the first place. We’re continuing to work on both improving the stability of subsequent firmware releases as well as the ease in which they can be applied to devices.

Thank you for your help and patience!

1 Like