Xenon - Serial monitoring question

Hello All.

I cant get any serial readouts from my Xenon.

So i have a Argon and a Xenon and the Argon is my “master” with a mesh network.
THe Xenon is connected to this network.

In Web ide they both show up and there seems to be no issues with the bords.

If i flash the Argon with this code

void setup() {
void loop() {
    Serial.println("Hello world5");

And then open particle CLI in Windows 10 Command prompt and enter “particle serial monitor” I get a readout of “hello world” all good.

Now if i do the same on the Xenon i do not get any readouts at all.

The LED on the Argon is very slow blinking cyan (Connected)
The led on the Xenon is fast blinking cyan ( Connecting to the Cloud)

According to the particle cloud its live and kicking.
Tried the same with putty and same result.

Why do i not get any serial readouts on the Xenon but i do get it on the Argon?

All the best

In default AUTOMATIC mode you code will not run while the connection is not stable.
You can add SYSTEM_THREAD(ENABLED) at the top of your code to decouple your code from the cloud connection.

1 Like

Hello And thank you.
Still dident work :frowning:

But i do not understand why i have a unstable connection. The argon and xenon is next to eachother.
I have tried to google some troubleshooting about this but cant find much about fast blinking cyan light on Xenon unit. Do it mean that its the mesh network that is unstable or the argon connection over wifi?

The xenon do not have a antenna but all guides i have seen about xenon they dont use an antenna, and i guess it should not be needed when they are so close to eachother.

I tried to publish a variable on the xenon to see if i could se it on particle cloud but it dident work.
when i published a variable on the argon it worked, so i bet i have some issues with the mesh network.

In the particle cloud i can see both unit and that they are connected to the created mesh network, i can see that it was just a few seconds ago they last handshaked. in the particle app on IOS everything also seems to be stable and nice.

Some forum threads about electron talks about key issues but as i understand this was pri version 1 and not sure its the same for a mesh network.

The units is flashed with latest firmware 1.4

How would i go about to troubleshoot this?

All the best

Maybe try some more distance (>15cm) between the two devices.
Can you also post a video (min. 30sec) of both devices doing their RGB signals?

Hello ScruffR.

Sorry for my late return.

Here is a a link to a move showing the RGB led.

The sounds in the background is from my two kids painting :slight_smile:

Please note i can only do it on the Argon since the xenon is fast blinking and cant be put in RGB mode. In the event for the xenon i get this message


Is there any limits on the naming? i use a underscore in the name (master_house) and also in the mesh name (Emil_mesh).

Beast me why the xenon refuse to connect.


I had exactly the same problem last week with a brand new Xenon. It turned out that the private key (?) was corrupted, Particle support was able to help me get the key reset and then set up the Xenon using the CLI.

When close together, 15 feet indoors, no mesh antenna needed, by my experience with an argon and xenon.
I had mesh issues when I changed the wifi networks. I had to create a new mesh network to make it connect finally.
I also had firmware issues when the new version came out and had to flash it with the CLI.

You might want to try a slower baud rate as well. Historically the higher the baud rate the more issues there were likely to be with serial communications.

Also, you have to make sure to close your serial monitoring program before flashing, I kept having that

Thank you all for the reply.

@scrounger crounger I will have a go to see if the Key have been corrupted, i have seen some threads on the forum about that however that should have been fixed in earlier patches if if my memory serves me right. Do you happen to have a walkthru about how you did to fix the problem?

@jwheasi Thank you for the distant information. I have flashed with a new firmware but not with the CLI,i simply did a firmware reset by the button on the Xenon and then with the iphone app installed the latest firmware. Is it different doing it by CLI?


@emilkl, @marekparticle helped me with the corrupt key. Given the device i.d. he was able to find a reference in your logs:

info: device disconnected {"reason":"udp verification failure","duration":"205ms","device_id":"e00fce68997e206fd2cadcca","conn_id":1354779}info: udp verification failure {"error":"Public key provided by device is invalid","device_id":"e00fce68997e206fd2cadcca","conn_id":1584890}

I reset my keys following the procedure here: https://docs.particle.io/support/troubleshooting/key-management/xenon/

Hope this helps!

@emilkl - if the issue persists, please open a support ticket with a link to this post and with your Device ID. I’ll be happy to talk a look for you!

By setting the devices to DFU and by the help of particle CLI i runned this commands

Place a device in DFU Mode and connect it to your computer.
Open your Terminal or Command Line and run: particle update.
Then, run: particle flash --usb tinker.

After that i installed my own code again and things started to work.