Argon blinking Yellow , with Red?

I am unable to put into save or Listening Mode. Is this DFU Mode ? See attached video for blinking. Video of argon blinking

From dfu-util.exe -l
Found DFU: [2b04:d00c] ver=0250, devnum=6, cfg=1, intf=0, alt=2, name="@External Flash /0x80000000/1024004Kg", serial="e00fce68e8022df2fd4796f1"
Found DFU: [2b04:d00c] ver=0250, devnum=6, cfg=1, intf=0, alt=1, name="@DCD Flash /0x00000000/1
016Ke", serial="e00fce68e8022df2fd4796f1"
Found DFU: [2b04:d00c] ver=0250, devnum=6, cfg=1, intf=0, alt=0, name="@Internal Flash /0x00000000/1004Ka,47004Kg,192004Kg,4004Kg,4004Kg,8004Ka", serial="e00fce68e8022df2fd4796f1"

From particle update
!!! I was unable to detect any devices in DFU mode...

Your device will blink yellow when in DFU mode.
If your device is not blinking yellow, please:

  1. Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.

  2. Release only the RESET/RST button while continuing to hold the MODE/SETUP button.

  3. Release the MODE/SETUP button once the device begins to blink yellow.

particle device doctor
particle device doctor

That does appear to be DFU mode. Although it’s a little hard to tell if the LED is blinking yellow due to the LED washing out in the vid, the rate of blinking is consistent with DFU.

If you are on Windows, make sure you have the latest Windows device drivers installed.

For Safe mode, release the SETUP button immediately when the LED flashes magenta, otherwise you’ll end up in DFU mode.

Device Doctor does not yet work with the mesh devices, BTW.

When the argon powers up , it doesn’t go threw any LED sequence , it goes strait to the this yellow , red blinking.

Holding both the mode and and reset button down at the same time. The led will never blink magenta , it does strait to this yellow blinking mode.

I just re-installed the ParticaleCLISetup for windows on windows 10. But particle update still doesn’t find any DFU devices. But dfu-util.exe does.

Not sure what I need to do to recover this argon.

Your device is definetly in DFU Mode otherwise it wouldn’t be found by dfu-util -l.
Does the device show up in DevMgr?
If not, you can try to install the DFU drivers manually via zadig

I personally prefer doing things manually instead of reyling on black-box-magic (aka particle docctor ;-))

BTW, an RGB LED has no yellow sub-LED if you see yellow with red then that’s because the red LED and the green LED are lit to produce the yellow colour. So depending on viewing angle you may be able to make out the component colours (red and/or green).
In the video you can clearly see a haze of red on the left side and green on the right side of the RGB LED. Consequently this is considered normal yellow.

But is DFU mode always this sticky ? As I can’t get out of it , and I don’t want to be in DFU mode .

if I power cycle the argon , it goes strait to yellow .

If I try to enter save mode , strait to yellow .

Not usually, but there are cases where it can be - mostly half finished updates tend to do that.
Or your code happens to call System.dfu() :wink:
Another possibility is when you have the device connected to your computer and the computer defaults to 14400 baud on the USB serial port (that's the magic baudrate for automated DFU flashing).
To exclude the latter you can try powering your Argon with a phone charger rather than off of a computer.

1 Like

Yes its in device manager as a
libusbk USB Device
- Argon DFU Mode

But particle update still says no device in DFU Mode.

So I assume I need to re-flash a new Device OS on the argon using dfu-util , I could not find anything under tutorials on how to do that.

Any writeup on how to do that ?

Interesting , if I change the current directory to where dfu-util is located ( C:\Users\deetl\AppData\Local\particle\bin ) and then run particle update I get a different message .

! There are currently no system firmware updates available for this device.

This suggests you have (at least) two different versions of CLI installed.
Check the version of each via particle --version - it should currently be 1.36.3.

If it's considerably lower than that it most likely doesn't know about Gen3 devices yet.

You should remove any older version of CLI via npm uninstall particle-cli and npm uninstall -g particle-cli and for safe measure also via the Windows Installer (Control Panel) and then reinstall the one and only version for your system via the most recent Windows Installer.

Yes , in the **\bin directory version is 1.36.3

any other directory I run particle --version from I get 1.15.0

I removed it. At least its not in the path anymore.

But now how to update a new Device OS ? As particle update still gives me
! There are currently no system firmware updates available for this device.

That's because there is no official release yet. particle update always updates to the most recent official release and never to a release candidate.

Try updating this way