ARGON Setup not happening

So, I got my Argon around Christmas and tonight I (finally) got round to trying to connect it to WiFI - but after a frustrating hour or so trying various things.,… here I am!

I suspect I have a couple of problems here.

The Argon looks like it’s doing all the right things. Flashing Blue LED indicating setup mode.

I downloaded the latest Android Particle App. Choose setup Argon and I get to the “photo your Argon barcode stage” and I cant get that to happen. Okay my phone is not latest gen by any means (Samsung S4) but normally has no problem with 2D barcodes. I tried with extra light and less light … but it never happens.

So, connected via USB to laptop (using exactly same setup - including cable - as I setup and flashed a Photon earlier today). System is a laptop Ubuntu V16 system. Run the CLI (V1.36.3 - after running the instructed npm command) and it runs, logs in but finds no attached device - okay scan Wifi - nothing found. Hmmmmm, well it’s still patiently flashing blue LED. Do, let’s try DFU mode. Get it into DFU mode… flashing yellow. Try again…

Ran the cli - nothing found on USB - still won’t find anything on WiFi. Reattached the Photon - and that is found no problem and get info from it.

Perhaps my Argon has a dead USB port - well don’t think so

dmesg | grep -i usb

says Linux has seen it - AND had logged that it went into DFU mode - so that all seems okay.

My conclusion is that maybe my CLI is out of date and knows not about Argons etc (though dunno why, I ran the suggested npm command) and that my poor old phone cam is just not up to reading this particular barcode. That being the case I will need to fix my CLI.

My node version is 4.4.1 which I think, from other posts I read on here is okay? However, can anyone validate my cli version?

Thanks in advance.
Alan T.

Samsung phones are known to take ages to properly focus with the Particle app (that's worked on). You can take a photo of the data matrix, blow it up on your computer screen and scan it from there.

CLI v1.36.3 isn't the latest version (1.37.0 is) but it should know the Argon.

I think node 4.4.1 is a bit old now.

Hi @scruffr

Thanks for the tip - I’ll try the bigging up the matrix in the morning. Wonder why its always the Android/Samsung functionality that gives issues and gets fixed last - are ALL designers and developers Apple fan boys! Just kidding :slight_smile:

If the photo thing doesnt work, I’ll see if Node will upgrade.

Thanks! WIll let you know.

Alan T.

1 Like

One thing that I noticed with scanning the codes, I had to get the camera very close, as close as it could be and still focus, and the code square had to be almost exactly in the middle of my screen. If I was too close and fuzzy - no go. Slightly too far and it didn’t seem to have enough resolution to detect the code, and off center didn’t work. So I had to hold quite steady and quite close. Don’t know if that will be any help.

Thanks guys,

I tried all those QR code related tips. I used my mid range Canon camera to take a sharp picture and put it on the PC monitor screen, In normal light and darkness I tried to make my phone read the code at various sizes and distances - but no go. I again tried scanning the real thing, steadying the phone on some books and supplying light from an LED torch as well as leaving on the phone’s flash led - and various combinations of these things for tens of seconds at a time - but again,… nuttin! I tried using the Samsung supplied QR code reader - and that can’t read the Argon either.

On a whim I tried scanning QR codes on the book covers using Samsung’s application - all three were recognised first time. I then tried scanning the book cover QR codes with the Particle scanner - never recognised any of them.

So I am starting to suspect two problems here. The Particle QR scanner and maybe a badly printed QR code may be the issue here? Looking at the product shots on the Specs page of the Particle site, my code looks different - it doesn’t go right to the edge of the white space at the top - but it does at the bottom. In the product pix there is white space equally all around - however, my QR code does look square so that may just be bad registration in the printing.

Anyway, I am out of ideas on this approach now so going to update my Node installation if I can, and try the USB method again.

Any all new ideas gratefully received!

Alan T.

Okay, so I tried to update node.js - but it can’t load anything later than 4.4.1 - checked the node.js site and yes, as @scruffr suggested, there are a lot newer versions (V10) - however the issues looks to be my 32 bit installation of Linux/Ubuntu. All the later versions seem to be 64 bit only which (although I didn’t see any message from npm) is probably why I am stuck on this old version?

I have a 64 bit Linux system so going to crank that up later and try again on there. Such fun :frowning:

The barcode on the Particle device are not QR barcodes they are Data Matrix so you are scanning 2 different types of barcodes.

Did you try scanning the Argon barcode with the samsung app? Have you tried using another barcode scanning app from the play store? Chances are samsung has their own barcode scanning implementation. The particle app uses a google library that a lot of apps on the play store use. If none of those apps can scan the barcode then its either the barcode is messed up or something is wrong with how the samsung camera interfaces with the camera API.

As an Android developer myself I can say that Samsung is notorious for messing with things in the Android SDK and special workarounds often need to be done to get them to work right


It’s not just a Samsung problem. I had similar problems on my LG phone with getting the app to focus on the QR codes. With good lighting and slowing moving the phone back and forth, I did eventually succeed in getting the app to focus and scan the codes. It took maybe a minute of fiddling each time I needed to scan an Argon or Xenon code.

1 Like

Thanks for the thoughts guys, I did try reading the code with the Samsung Optical reader app, but it didn’t manage to read the Argon label. I will go look for a different reader later in the week though.

In the meantime I tried what I said earlier to get my Argon setup via USB. I installed the particle/Node/dfu-util stack on my 64-bit Ubuntu machine and tried it all again. Although I did indeed get a far newer version of Nodejs (V8.2 now as opposed 4.4 on the 32 bit machine earlier today) The particle cli is still not detecting my brand new Argon on USB, and when I proceed to check for stuff in wireless AP mode, it finds nothing

QUESTION: Does the Argon need to be in any special mode to be found on USB? I have it at blinking blue mode. Should that allow the CLI to find it?

I also tried “dfu-util --list” which, with the Argon is blinking blue, finds nothing (thus my question) - however, when I put the Argon into DFU mode (blinking yellow) that same dfu command finds it fine. However, leaving it in dfu mode and running the CLI setup still finds nothing. :frowning:

One observation - when you go past the USB scan and the CLI starts looking for a device on wireless, it says its looking for “Wild photons” - so are we really sure that the particle CLI has been updated to know about the newer devices such as my Argon? I am now running CLI version 1.37.0.

I’m wanting to believe, but remaining unconvinced, that my device is faulty; it SEEMS sane and does all its button responses right, which makes me sceptical that its a bad 'un!

Thanks again for any thoughts.

If it isn't running 0.8.0-rc.25 or later then you can't setup WiFi via USB.

Not surprising since blinking blus is not DFU Mode hence the device is no DFU device for your system.

What CLI command have you tried to establish that?

Yes CLI 1.37.0 is aware of the Argon but the Argon can't be setup via particle setup (yet) since that command expects a SoftAP device which the Argon doesn't expose.

I'd try updating the device to 0.8.0-rc.27 as shown in this post

After that you should see the device via USB Serial and should be able to run particle serial wifi (in Listening Mode)

1 Like

So all that worked okay - Thanks @ScruffR. The remaining issue is I still can’t read the barcode with my phone and my 64 bit Linux m/c does not have a wireless (only wired) network port - tried the 32bit machine with the Argo re-flashed as described above, but I think the software on there is too old for Argons. Going to try to borrow a USB WIfi for my LAN only machine to see if I can attached via WiFi now.

Thanks guys.
Alan T

1 Like

No luck with a blown-up image on screen or slowly trying to focus manually by carefully adjusting the distance either?

There were a few Argons with borked data matrices but Particle thought they caught all of them before releasing them into the wild. Maybe you were one of the lucky ones (like most Elites :wink: ) who got one of these.
Maybe you can take a photo of your data matrix (including the serial number at the bottom) and send that to @rickkas7 in a PM to have him check whether this is one of the dud stickers.
If so, he can create a new data matrix and send it to you.

1 Like

Hiya. Yes, I tried all that and spent overall about a half hour trying again on the real label - no joy though. Have sent picture to Rick for him to take a peek. Thanks again.

1 Like

Okay so all sorted now.

Got a new barcode from Rick, tried to scan that. STILL no dice my phone can’t read it, not even when magnified on a screen. Then, a brainwave, try to read the Argon barcode with my Samsung tablet instead!

Installed the particle app on tablet and tried to scan the original again using its camera; after 20 seconds or so PING!! All captured and plain sailing from then on - and all done now.

So, sadly (and I blush at this point) this part of the problem seems to have been that my Samsung S4 phone camera (which takes perfectly good pictures and scans other barcodes just fine is not up to the job of reading Argon labels.

On the way through this though I discovered that:

a) You cant install up to date Node and Particle-Cli on 32-bit Ubuntu/Linux systems cos they stopped producing a 32bit Node distro some time ago. Also, (a side issue I didnt mention before) if you run particle CLI as non-root on such a system, you get a message saying that the software is corrupt(? I think it uses that word) and needs to be reinstalled. If you sudo -s and try again as root, you get no such message.

b) You can’t setup an Argon via the USB port alone (though you can reflash it and apply updates). I expect that is being addressed pretty soon, but if not, it’s a limitation worth highlighting in a startup message in the next minor release - cos currently nothing tells you it’s not Argon friendly.

Many thanks to @Scruffr and @rickkas7 and all the other respondents to this issue. I’m calling it done now and sitting in the corner with my clearly defective phone camera for a while, considering that device’s immediate future :slight_smile: