Argon - Visual Studio - CLI - USB - "No devices found"

I have a handful of Argons and so far not too many problems, but I have one now that I cannot get recognized via USB. Have done multiple ‘factory reset’ and set-ups via iPhone app. Once set-up via app I can ping it and I can see it listed from CLI - “particle list” but not “particle usb list”. I have tried different cables and used those cables on other Argons w/o problem. Setting up as solo devices - not mesh. F/W via app says 1.4.4. (Restarted VS Code and cleaned workspace, etc. multiple times.)

I believe this unit was communicating via USB and I loaded my project on it a few times but won’t swear to it.

Searched the docs and looked thru here but didn’t find anything that quite matched this problem. Hoping it’s something obvious I overlooked.


A few more details - though I can see it via cloud (as mentioned) I cannot flash it using either the VSCode Workbench or the browser IDE. In the latter I was just trying ‘blink LED’ and it failed. Health check says things are good. Signal strength good, etc. Not seeing any replies yet, so may just set this one aside and see if I can figure it out sometime when I have more time to dig.

What operating system on your computer?

If Windows, does it show up in the Device Manager?

If Mac, does it show up with

ioreg -p IOUSB -l -w 0

If Linux,


Hi Jim- That sounds frustrating! What is the color of the status LED?

I’m using a Mac w/ Mojave (req’d for some legacy 32 bit apps). I checked using ioreg and it doesn’t show up. Moved it to a different port (direct instead of hub) and still not there. Unplugged everything except Argon. No luck.

Once plugged into USB it searches and finds network then LED is ‘breathing cyan’. I can ping/nyan it from iPhone app and from browser console. Signal reported is ‘strong’ and health check says all good.

From VS Code - CLI I was able to flash tinker to it, but calling digitalwrite D7=HIGH fails.

We’re going to use a bunch of these to build pH monitors so would like to know how to get out of weird situations like this.


Update - I circled back to this unit and tried the ‘Device Restore Over USB’ tool which someone pointed me to that sorted out issuse with a few devices. No luck here. Can’t see it which is not surprising based on above. Am using a different laptop - still a Mac.

Successfully flashed Argon 3.10 binaries from the Github repo using CLI (–cloud). I can see it via console still, still healthy. When I connect via Particle app on phone it still says 1.4.4 - and it doesn’t recognize that tinker is running. Flash tinker again via CLI and try it command line (turn on D7 LED) - doesn’t work.

Have another instance of this - Argon unrecognized on USB. I had 6 Argons built up as prototypes, 5 of them were fine. My procedure right now:

  1. Set up via iPhone app as non-mesh and name them.
  2. Use the ‘Chrome Restore’ tool to get them to 3.20 rc (this batch we bought are 1.4.4).
  3. Flash our code via VSCode-Particle workbench using USB.

On this one, maybe I disconnected early after step 2 while it was training up to connect to network. Not sure and may have done that with others. On earlier case I’d done a lot of debug programming and was willing to accept that stuff happens, but on this one it was fresh out of the box. I can’t communicate with it via WiFi/phone app, the status LED doesn’t illuminate, so it appears to have just bricked. Any ideas appreciated.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.