Need help recovering an Argon

I’ve got an Argon that’s unresponsive. It powers up flashing Green (or yellow?), and never goes anywhere from there. I tried to recover it using steps given to me earlier today to recover a Photon (but substituting the appropriate Argon binaries), but no luck. It says no DFU device is found.

I also don’t see it in my device manager under Ports. But it does cause the device manager to refresh each time I plug or unplug it from the laptop, so at least the device manager is aware of its existence.

Is there anywhere to go from here?

You’re in luck here. Gen 3 devices have a factory reset option. I’d start with that here:
https://docs.particle.io/tutorials/device-os/led/argon/

About 2/3rds of the way down.

1 Like

Hmmm… that seemed like a great idea, and I felt lucky, but not so much. :frowning:

It initially powers up with a relatively rapid flash (maybe 3 or 4 Hz) of yellow or green (kind of looks more green to me).

So then I follow their process…

To factory reset, hold down the MODE button and tap RESET. The status LED will blink:

** Magenta (red and blue at the same time, safe mode)*
** Yellow (DFU mode)*
** Fast blinking yellow (restore factory firmware)*
** Fast blinking white (factory reset)*

It goes into the Magenta flash mode, and then back to the original power-up mode (rapid yellow/green flash). But it never goes any further than that.

I’m not convinced the yellow/green flash is DFU mode, because the CLI says it can’t find a DFU device. To be fair though, the Device Manager doesn’t seem to see it either (or at least not where I can find it).

Any tips on where to go from here are greatly appreciated.

Here’s another interesting tidbit…

When I try to ping it from the console, nothing happens. I don’t even get the message that says a ping was sent and I may have to wait up to 15 seconds for a response. I literally see no indication at all that I tried to ping it except that the ping button on the console blinks once as I click on it.

If you are not sure, try putting the device into DFU Mode and see whether this is the color you are seeing after startup :wink:

If it’s not yellow you will not find it as DFU device.

If it keeps blinking green that indicates your device is not connecting to WiFi - rapid flashing green (~10Hz) would indicate IP acquisition.

What happens when you put the device in Safe Mode?

I cannot put it in DFU or Safe Mode.

10Hz!? I don’t think I’ve ever seen one of these devices flash that fast.

Can you clarify that?

You said this above

When you let go of the MODE button then, what happens?

This would be the same speed as the rapid green I was referring to.

I think I see what was unclear. I posted the instructions I followed. But those don’t represent the results I got. It comes up blinking a yellow/green - fairly rapidly (3-4Hz).

When I try to take it through the prescribed sequence. It will reach the blinking magenta phase, but as soon as I release the Mode button, it immediately reverts to the blinking yellow/green 3-4Hz mode. I am not able to get it into any other mode.

And when it’s in that mode, the CLI doesn’t recognize it as a DFU device.

Here’s a short video of the yellow/green 3-4Hz mode. But I think it looks more definitely green in this clip than it does to my eye for what that’s worth.

Start with taking the device out of that anti-static sponge :wink:

BTW, yes. That is green blinking indicating “searching for WiFi network”.

1 Like

Holy crap - if I had the capacity for shame that would definitely be embarrassing.

OK - that made a slight difference. Now when I hold the Mode button and click/release the Reset button it goes into a Magenta blinking mode, then the green blinking mode, and finally the white (much faster) blinking mode. I release the mode button when it’s in the white much faster blinking mode - and it immediately returns to the green blinking mode.

So I then try to flash firmware onto it via the CLI and get this message…
“Error writing firmware…No DFU device found”

Hi @spork

I think you are in great hands with @ScruffR, not much I can add other than maybe checking whether you have tried getting the device in DFU mode via CLI (or Workbench)

Put the Argon in DFU mode (blinking yellow) by holding down MODE. Tap RESET and continue to hold down MODE. The status LED will blink magenta, then yellow. Release when it is blinking yellow!!

Then with the device connected via USB, use the following in terminal/workbench:

  • particle usb dfu

Let us know.

Regards, Friedl.

1 Like

I just downloaded workbench, but have not yet familiarized myself with it. Unfortunately I’m not able to get this one into DFU mode. :frowning:

Can you share a video of the process of (trying) to put the device in DFU Mode plus 10-20 sec after that?

to add and clarify… you should also be able to do this via Terminal (Mac OSx) or the cmd.exe (Windows). I doubt you “need” Workbench.

so you can either use buttons to try and get into DFU mode OR you can use terminal (or from cmd.exe in Windows) and * particle usb dfu command. Is neither one working?

I got:
particle: Unknown command: “usb”

Video on the way. There’s time to put some popcorn in the microwave.

@spork

Ok, let try this;

Open Visual Studio Code

  1. Click on Workbench, assuming it is installed already
  2. Click in Terminal and then choose new terminal
  3. Then, at command prompt, enter particle usb dfu

Let me know if this works please. I need to study a bit, but will check back in soon.

Regards, Friedl.

This message would suggest you got a really old version of CLI.
Can you run particle --version and also particle --help?

About your video, it appears the MODE button is not working (properly).
When you press/hold MODE and then tap RESET you should not see white nor green at any stage but your video suggests exactly that.
You can try connecting the MD pin to GND (which is the same as holding MODE) and then hit RESET again - then you should see distinct magenta and yellow.
Removing the connection MD-GND when you see yellow should leave the device in DFU Mode.

Can you provide a video of that too?

1 Like

OK - I just tried connecting MD to GND. It behaved exactly the same as in the previous video. I can’t do a video right now, but can later today if you think that will help.

OK - I just tried this. I get the same result that I do through the CLI. The response was…

particle: Unknown command: "usb"