Need help recovering an Argon

Here are the results…

c:\files>particle --version
1.24.1

c:\files>particle --help
Usage:

Commands:
help Provides extra details and options for a given command
library Manages firmware libraries
project Manages application projects

Global Options:
-v, --verbose Increases how much logging to display [count]

-q, --quiet Decreases how much logging to display [count]

Options:
–version Show the version of particle-cli installed. [boolean]

For more information, visit our documentation at https://docs.particle.io

particle-cli 1.24.1

Yup, this CLI version is ancient - currently we are at 2.8.0
This may also explain why you couldn’t USB flash the Argon as it was not known to CLI back then.

But when you cannot enter DFU or Listening Mode it’s probably best to file a support ticket at support.particle.io

2 Likes

@ScruffR if he updates the CLI, any chance the magic baud rates would get him into DFU?

It’s worth a try, but since the device doesn’t seem to get listed in Device Manager (if IIRC from another thread) I’m not positive it will work.
I fear a previous flashing attempt may have left the device in a limbo state.

1 Like

@spork -

As @ScruffR pointed out, the CLI version is out of date, let’s hope this is the cause. You can update via workbench following the instructions as per the screen grab.

Alternatively, you can try via CLI by running the command particle update-cli either from Terminal or Workbench CLI.

Hope this helps. If not, you might have as ScruffR mentioned, submit a support ticket.

Good Luck!
Friedl.

Hey guys, thanks for all the suggestions. I just ran the cli-update. Sadly, the result is that CLI is now completely broken on my machine. So I’m trying to do a new install from scratch.

Once it’s done I’ll see if it can put my Argon in DFU mode. If not, I’ll go ahead and submit a support ticket.

Unfortunately the new install didn’t fix it. Now when I try to use the CLI, I always get this…

C:\Users\rickcavallaro\Desktop>particle login
C:\Users\rickcavallaro\AppData\Roaming\npm\node_modules\particle-cli\dist\app\cl
i.js:144
async runCommand(args) {
^^^^^^^^^^
SyntaxError: Unexpected identifier
at Object.exports.runInThisContext (vm.js:76:16)
at Module._compile (module.js:542:28)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object. (C:\Users\rickcavallaro\AppData\Roaming\npm\node_modul
es\particle-cli\dist\index.js:8:13)
at Module._compile (module.js:570:32)

So then I tried running “particle usb DFU” through the terminal in Workbench, and got the same thing. :frowning:

Tragically, I just uninstalled CLI from my laptop and did a new clean install - and I’m still getting the same response. I seem to be losing yardage :frowning:

More info on my CLI situation.

It kind of looks like it installed the new version of the CLI to a different location from the old. So I went to the location where it said the new version was supposed to be installed, and tried to run if from that location. It appears to work and it shows that it’s version 2.8.0. So I went in and edited my PATH variable so that the old location comes after the new one. So I now seem to have the updated CLI working.

I tried running “particle usb dfu” on my Argon with the updated version. It didn’t give any errors, and it did come back with “Done”. But it didn’t actually put the Argon into DFU mode.

In fact I still can’t put the DFU into safe mode, listening mode, DFU mode… And it still doesn’t show up in the Devices Manager.

So now I’m going to go ahead and submit a ticket as ScruffR suggested.

Thanks again for bearing with me. I’ll post here when I learn more.

Hi @spork -

I am sorry to heat about the Argon. At this stage I agree with @ScruffR, support ticket is the way to go. I had some issues with a Photon a while back and got sorted pretty swiftly with the help of support.

Best of luck!!
Friedl

Thanks. I just this moment submitted the support ticket with all the info I could think of. Fortunately, this is a relatively low priority. Because you guys helped me get my Photon straightened out, I’ve actually completed the immediate project. But of course I’d like to get this thing working on general principle. It’s basically brand new and never been used.

1 Like

Have you also referenced this thread (and possibly the other where the whole journey started)?

This might help the support team to understand what lead up to the ticket.

2 Likes

@spork

This will give them an idea of what you have tried already and save some time going backwards and forwards with things already attempted.

Pleasure, glad we could help :slight_smile:

Of course… I still have a Photon “in ICU” which I am hell-bent at fixing, but I think I should let him go as I have not even been able to debug using the debug shield :rofl:

1 Like

I didn’t provide a link to the thread, but I did tell them that I’ve been working through the problem on the forum, and I mentioned that you have been helping me. I wondered whether I should include a link to the thread, but I kind of thought that might be more than they wanted to wade through. I’ll be happy to give them the link though.

There is the thread where you guys helped me sort out the Photon. At the very end of that thread I tried to take basically the same approach with the Argon, but with no luck. I can give them that as well. I presume they’ll contact me and I can give them the links at that time - right?

I got an email from support and responded with links to both threads.

Thanks again.

2 Likes

Unfortunately, even though the email from support said I’d be hearing from them in 1-3 business days, I have not heard from them.

ping @no1089

2 Likes

Please PM me your ticket ID so I can follow up.

3 Likes