Argon won't enter Safe mode, DFU mode, or initiate a factory reset

Hi all. I have an Argon that is blinking red. According to the reference docs, it's an Assertion Failure. 10 links between 2 SOS patterns. I'm a high school teacher and use the Argon in one of my courses. The students weren't doing anything advanced. Just connecting a button for the first time.

My problem is, I can't get the Argon to enter safe mode, DFU mode, or initiate a factory reset. I tried the following: Hold down the Mode button and the Reset button. Release only the Reset button.

When both are held down, the LED indicator turns white. When I release only the Reset button, it instantly returns to blinking red.

When I try to hold down only the Mode button to put it into listening mode, the LED indicator never changes colors. Just continues to blink red.

It's almost as if the Mode button isn't functioning.

What should I try next? BTW, I tried to open a support ticket but their support site has a tree of questions you have to answer and my answers take me to an end point without a link to open a ticket. Kind of stuck there as well.


Hi @drlaw - we provide support in the Community for Free and Growth users. @jalbersr can help you here, though the issue is likely either a serious misflash on the device or damage to the unit.

Hi @drlaw!

Maybe is a hardware failure. But first, you can try a couple of things and tell us how it went. Here are some links about using the CLI to induce the DFU mode or the Safe mode through USB, to see if the device is still responsive and you can get back your device. Here are some instructions about installing and using CLI. Please keep me posted!

1 Like

I don't think this will help, but also try:

  • Remove USB power
  • Hold down the MODE button while plugging in USB power and continue to hold down MODE.
  • See if the LED changes mode. It should normally blink white, then magenta (red and blue at the same time), then yellow. If you get to yellow, release the button and see if it stays in MODE.

In case it's actually the physical button:

  • Remove USB power
  • Put the Argon in a breadboard. Connect the MD pin to GND.
  • Plug in USB power

Thank you for all your responses!

@jalbersr I have tried both those things already but to be on the safe side, I tried both these commands again:
particle usb dfu
particle usb safe-mode

They both give the same error. "No devices found".

I also tested the USB port on the computer by plugging in another Argon to make sure I can communicate with that Argon. It was successful. The port itself is fine.

@rickkas7 I had already tried your second suggestion but it didn't work. I had never tried your first suggestion before so I gave it a go. It just blinks red. There are no other colors before the red blinking begins.

If it is a damaged Argon, any clues to what could have caused it? The students had the Argon on breadboards already. We had already worked through a couple of circuits with just an LED. There is no food and drinks on the table. Could the student have brushed the top of the Argon with something conductive? Is that enough to render it damaged beyond recovery?

It could be ESD damage. If you have a Particle Debugger, generic CMSIS/DAP debugger, or Segger J/LINK you might be able to recover the device by SWD/JTAG if the flash memory was corrupted but still functional.

It's also possible that the device cannot be restored if there is a hardware failure.

1 Like

Nah, I don't have any of those devices. Been meaning to get one so I can fix some of these Photons and Argons I have lying around.

Thanks for trying to help. =)

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.