Argon dark after firmware update

After remote updating firmware on several Photo devices, I flashed the latest default firmware to a Argon device. At this point the Argon led went dark. Attempting to reset, mode+reset does nothing. Can not get into DFU or safe mode. The only time I get a response is when pressing the hold button when adding power. Then the device flashes red/blue, green/yellow and then white before going dark. Argon worked great for over 10 months. Any help to revive the ‘dead’ Argon would be greatly appreciated. If it helps, I have the debugger (but not able to set DFU). Thanks!

Can you help with Device OS (old and new)? IMHO plugging in the USB putting in DFU mode and using the terminal to load/flash System-part1, Tinker and then with --serial Bootloader will solve your problems.

This would probably call for a support ticket.

But I don't quite understand this

Should this rather be "press/holding the MODE" button?

But when you do that and then release the MODE button as soon you see the "green/yellow" what does the device do then?

Apologies I didn't notice the

Can not get into DFU or safe mode.

Have you been able to get it into safe mode or DFU mode in the past?

Can you get it into serial (flashing dark blue) mode? You would then be able to upload the bootloader which is likely the problem.

1 Like

I meant ‘Mode’ button. ‘Hold’ was a tablet typo. Pressing and releasing the MODE button does nothing.

You said

but then you say

What I meant to ask was: When you do what you described in the first quote but release the button when you see yellow - instead of holding it further till white comes -, what happens then?

Hold was a typo. Meant Mode.

Yes, I have successfully set DFU, safe mode and serial states over the past year. Have experience with multiple Photon, Argon and Xenon devices.

For this particular device, once power is plugged in, there is no response to any button combination. This includes both MODE and RESET. Without the ability to get into setup or DFU mode, it limits options to flash new firmware or use the debugger to update the bootloader.

The Argon was at OS level 0.9.0. Was attempting to upgrade to 1.4.2.

I created a support ticket on Wednesday. Hoping to get a response soon.

I plan on using a spare Argon to restore operations including the mesh network/Xenons. Still like to understand how to reduce risk of device failure during remote firmware upload and hopefully get this Argon working again. The Argon was operating non stop (no reset) for many months. Is it possible, there was memory leakage over time that led to the firmware failure? The device was working perfectly prior to the firmware upgrade.

Thanks for the responses!

You mean not even the D7 LED goes dim when you press and hold the RESET button?
In that state the device should actually attach the internal JTAG pull-up resistor causing the dim D7.
If that doesn't happen I'd suspect a more major issue with the controler.

Via JTAG/SWD you would not need DFU mode, but given the lack of dim D7 I'm not sure this is a viable way.

Update: The D7 LED is now lights when I plug in power. Also the charging LED flickers yellow. For the past several days, both were dark. Also tried changing USB/power without change. Still no response to MODE or RESET buttons.

Can you try these?

With a dim D7 LED you should be able to use JTAG/SWD

Turns out the D7 LED/charging LED was lit because the Argon was moved to the foam carrier.
Was able to get the Argon in DFU mode and used the Debugger/SWD to flash the Argon bootloader and soft device. Some progress. Unfortunately still can not get the Argon to operate correctly.

Looks like it is working again. Using CLI and particle update over serial finally restored normal OLED operation

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.