Argon SOS Wont Enter DFU or Listening Mode

argon
Tags: #<Tag:0x00007fe21d9023b8>

#1

Hello!

My Argon has entered an SOS state with 10 blinks, which the reference docs list as an assertion error. I have tried using the particle device doctor to solve the issue, however in its current state the cli command does not recognize the argon board while its plugged in via serial. We cannot use particle flash either, as the board cannot be put into dfu mode.

This post:


discusses similar issues, however the solution that is provided also requires the argon be put either in dfu or listening mode.

Currently, our argon will not change mode. Holding RESEST and MODE, then releasing/tapping reset sends the argon briefly into magenta (SAFE?), and then immediately into quickly flashing light green. Not yellow like dfu, or green like searching for internet, but a light green. After this, it returns into SOS, and continues to be unresponsive.

Any insight into how to progress would be sincerely appreciated! Thank you.


#2

That’s not supposed to happen, but a borked MODE button might explain that too.
Can you try a jumper wire from MD to GND instead of press/holding MODE?
Can you also post a video of the process?
Have you taken the Argon off the anti-static sponge it came on?


#4

MD to GND did the trick! Maybe it was a borked MODE button. We did take the argon off the anti-static sponge, but sit it on an ESD mat and ground ourselves before using. Not sure what caused it, but we really appreciate the quick tip!

Once in DFU mode the steps from @jvanier worked great.
Thanks again!