Boron SOS 10 flashes and usb yellow led fast blinking

Hi, I'm having a problem similar to this Argon SOS Wont Enter DFU or Listening Mode - #5 by Jeff_Burch with Boron.
All happened after a low power shutdown. I'm not able to communicate via USB with the board. I can not set to DFU mode.
I tried the different solutions proposed on various topics, but with no success.
I tried flashing the firmware with particle debugger via web browser, by dragging the firmware on the debugger and with openocd: the red led turns down and it seems to flash, but as it finishes, the SOS red led blinks 10 times again.
Trying on terminal using openocd I get this output:

bin/openocd -s share/openocd/scripts -f share/openocd/scripts/interface/cmsis-dap.cfg -f share/openocd/scripts/target/nrf52-particle.cfg -c "adapter_khz 1000" -c "transport select swd" -c "init" -c "soft_reset_halt" -c "nrf5 mass_erase" -c "flash write_image /home/mole/Scaricati/boron.hex" -c "reset" -c "exit"
xPack OpenOCD x86_64 Open On-Chip Debugger 0.11.0+dev (2022-03-25-17:31)
Licensed under GNU GPL v2
For bug reports, read
Info : auto-selecting first available session transport "swd". To override use 'transport select <transport>'.
DEPRECATED! use 'adapter speed' not 'adapter_khz'
DEPRECATED! use 'adapter speed' not 'adapter_khz'
adapter speed: 1000 kHz

Warn : Transport "swd" was already selected
Info : CMSIS-DAP: SWD  supported
Info : CMSIS-DAP: Atomic commands supported
Info : CMSIS-DAP: FW Version = 0254.2
Info : CMSIS-DAP: Serial# = 31043602313896201239333437353533a5a5a5a597969908
Info : CMSIS-DAP: Interface Initialised (SWD)
Info : SWCLK/TCK = 1 SWDIO/TMS = 1 TDI = 0 TDO = 0 nTRST = 0 nRESET = 1
Info : CMSIS-DAP: Interface ready
Info : clock speed 1000 kHz
Info : SWD DPIDR 0x2ba01477
Info : [nrf52.cpu] Cortex-M4 r0p1 processor detected
Info : [nrf52.cpu] target has 6 breakpoints, 4 watchpoints
Info : [nrf52.cpu] external reset detected
Info : starting gdb server for nrf52.cpu on 3333
Info : Listening on port 3333 for gdb connections
requesting target halt and executing a soft reset
target halted due to breakpoint, current mode: Thread 
xPSR: 0x01000000 pc: 0x00000998 msp: 0x20000400
Info : nRF52840-xxAA(build code: D0) 1024kB Flash, 256kB RAM
Info : Mass erase completed.
Info : Flash write discontinued at 0x0002659c, next section at 0x00030000
Info : Flash write discontinued at 0x000acf7c, next section at 0x000b4000
Info : Flash write discontinued at 0x000b5bfe, next section at 0x000d4000
Info : Padding image section 2 at 0x000b5bfe with 2 bytes (bank write end alignment)
Info : Flash write discontinued at 0x000d4400, next section at 0x000f4000
Info : Padding image section 4 at 0x000ff426 with 2 bytes (bank write end alignment)
wrote 727360 bytes from file /home/mole/Scaricati/boron.hex in 16.744459s (42.421 KiB/s)

Then the board starts flashing SOS 10 times again and nothing changes.
Tried also to upload tinker hex made with Hex generator and using Particle debugger: same result.
Any hint?
Thank you.

Did you try the device restore hex file with the debugger? That would be the next step if not.

If it still doesn't work after a SWD/JTAG restore, it may be a hardware failure. That the writes didn't complete in your log above isn't a good sign.

Also make sure you power the device with both USB and the debugger (also connected by USB). The debugger alone doesn't supply sufficient power and the device may reset unexpectedly causing the writes to fail.