Argon won't leave DFU mode, can't flash

Hello,

So I have a Particle Argon and wanted to flash a simple test sketch via the Web IDE. Somehow the Argon started entering safe mode when I flashed it with it. Then afterwards I was unable to flash it again because I got a timeout. I then disconnected the Argon from my PC and connected it again. It then started in DFU mode and I don’t get it to leave it.

I tried to start safe mode by holding mode and reset and releasing mode when blinking magenta. I tried to hold mode for 10 seconds until blinking white, just enters DFU mode again. I installed the CLI and tried to do particle serial flash tinker -v. I then get ordered to keep holding Setup(mode) until it starts blinking blue. But it won’t do that.
If I just press enter while in DFU mode I’m getting Error writing firmware: No serial port identified.

I really don’t know what to do anymore. Can I somehow get my Argon working again?

Try particle update -v followed by particle flash --usb tinker -v

Glad you got it resolved, I literally just went through this as well. Did you try to go over to that python firmware?