Argon stuck in dfu mode after sos+10

Hey all, got my argon stuck in SOS+10, after a lot of flashing attempts it appeared to be recovered. but now seems to be stuck in dfu mode. tried a lot of steps to no avail, when I tried particle doctor, I get this:

The Doctor didn't complete sucesfully. Error writing firmware: file does not exist and no known app found.
VError: Error writing firmware: file does not exist and no known app found.
    at Promise.resolve.then.then.then.then.then.then.catch.err (C:\Users\Kevin\AppData\Local\particle\node_modules\particle-cli\dist\cmd\flash.js:198:13)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:189:7)
caused by: Error: file does not exist and no known app found.
    at Promise.resolve.then.then.then (C:\Users\Kevin\AppData\Local\particle\node_modules\particle-cli\dist\cmd\flash.js:117:17)        
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:189:7)

I’ll take any drastic steps you have to offer… tried to factory reset and that failed for me as well.

thanks for any help

Can you check if particle --version returns 1.41.0?

If so (or higher), you can try

particle flash --usb tinker -v
particle update -v
particle flash --usb tinker -v

If not, run particle update-cli

thanks for the quick reply,
first tinker flash ran but put argon back in sos+10
back in dfu, particle update ran and left the argon in listen mode
back in dfu for final flash left argon in listen mode again.
hmm… when I bring up putty and type ‘c’, get Device claimed: no… guess I’ll work on reclaiming.

did a ‘w’ in listen mode, now breathing cyan… yay! so much easier with your help! thanks

1 Like

OK, since I am on a roll, here are my current issues with the Argon:

  1. I got here in the first place trying to setup a debug session with particle programmer. it would be great if someone could publish a step by step procedure for getting this to work… I spent several days with the programmer shield and a photon… tried all kinds of things that didn’t work, suddenly it did work and I have no idea why. and I never was able to complete the debug session without crashing the photon sos+x.

this next one is just an annoyance… I recently started using the serial logger, but I am getting a ton of messages presumably from the firmware… they look like trace level messages, but they are set as INFO, any way to filter these out?

0000024994 [gsm0710muxer] INFO: Mux channel 2 already opened
0000027890 [net.ifapi] INFO: Netif wl3 link UP
0000027890 [system.nm] INFO: State changed: IFACE_UP -> IFACE_LINK_UP
0000028140 [hal] INFO: DNS server list changed
0000028141 [system.nm] INFO: State changed: IFACE_LINK_UP -> IP_CONFIGURED
0000028142 [system.nm] INFO: Checking gateway status with the device cloud
0000028143 [system] INFO: Cloud: connecting
0000028145 [system] INFO: Read Server Address = type:1,domain:$
0000028146 [system] INFO: Loaded cloud server address and port from session data
0000028147 [system] INFO: Cloud socket=0, connecting to
0000028149 [system] INFO: Cloud socket connected
0000028150 [system] INFO: Starting handshake: presense_announce=0
0000028150 [comm.protocol.handshake] INFO: Establish secure connection
0000028393 [comm.dtls] WARN: session has 0 uses
0000028399 [comm.dtls] INFO: (CMPL,RENEG,NO_SESS,ERR) restoreStatus=0
0000028400 [comm.dtls] INFO: out_ctr 0,1,0,0,0,0,0,106, next_coap_id=4e
0000028401 [comm.dtls] INFO: app state crc: cached: d366bb72, actual: 465617de
0000028401 [comm.dtls] INFO: restored session from persisted session data. next_msg_id=78
0000028402 [comm.dtls] INFO: session cmd (CLS,DIS,MOV,LOD,SAV): 2
0000028403 [comm.protocol.handshake] INFO: Sending HELLO message
0000028642 [comm.dtls] INFO: session cmd (CLS,DIS,MOV,LOD,SAV): 4
0000028643 [comm.protocol.handshake] INFO: Handshake completed
0000028645 [system] INFO: Send spark/hardware/max_binary event
0000028647 [system] INFO: Send spark/device/last_reset event
0000028650 [system] INFO: Send subscriptions
0000028651 [comm.dtls] INFO: session cmd (CLS,DIS,MOV,LOD,SAV): 4
0000028652 [comm.dtls] INFO: session cmd (CLS,DIS,MOV,LOD,SAV): 3
0000028653 [comm] INFO: Sending TIME request
0000028692 [comm.protocol] INFO: Posting 'M' describe message
0000028694 [comm.protocol] INFO: rcv'd message type=1
0000028695 [system] INFO: Cloud connected
0000028696 [system.nm] INFO: Checking gateway status with the device cloud
0000028797 [comm] INFO: Forcing a cloud ping
0000028799 [comm.protocol] INFO: message id 80 complete with code 0.00
0000028800 [comm.protocol] INFO: rcv'd message type=13
0000028901 [comm.protocol] INFO: message id 81 complete with code 0.00
0000028901 [comm.protocol] INFO: rcv'd message type=13
0000029002 [comm.protocol] INFO: message id 82 complete with code 0.00
0000029002 [comm.protocol] INFO: rcv'd message type=13
0000029043 [vdots   ] INFO: WiFi Connected - SSID: KevZone2.4
0000029044 [vdots   ] INFO: waiting for Serial Connection
0000029103 [comm.protocol] INFO: message id 83 complete with code 0.00
0000029103 [comm.protocol] INFO: rcv'd message type=13
0000029204 [comm.protocol] INFO: message id 84 complete with code 0.00
0000029204 [comm.protocol] INFO: rcv'd message type=13
0000029305 [comm.protocol] INFO: message id 85 complete with code 0.00
0000029305 [comm.protocol] INFO: rcv'd message type=13
0000029406 [comm.protocol] INFO: message id 86 complete with code 2.05
0000029406 [comm.protocol] INFO: Received TIME response: 1559093845
0000029407 [comm.protocol] INFO: rcv'd message type=12
0000029508 [comm.protocol] INFO: message id 87 complete with code 0.00
0000029508 [comm.protocol] INFO: rcv'd message type=13
0000030046 [Msg     ] INFO: MsgPacket default Constructor
0000030047 [Msg     ] INFO: MsgIO constructor
0000030048 [LoopTmr ] INFO: loopTmr init
0000030595 [comm.protocol] INFO: Posting 'S' describe message
0000030601 [comm.dtls] INFO: session cmd (CLS,DIS,MOV,LOD,SAV): 4
0000031045 [LoopTmr ] INFO: loopTmr init
0000031144 [comm.dtls] INFO: session cmd (CLS,DIS,MOV,LOD,SAV): 3
0000031144 [comm.protocol] INFO: rcv'd message type=1
0000031248 [comm.protocol] INFO: Posting 'A' describe message
0000031251 [comm.dtls] INFO: session cmd (CLS,DIS,MOV,LOD,SAV): 4
0000031254 [comm.dtls] INFO: session cmd (CLS,DIS,MOV,LOD,SAV): 3
0000031257 [comm.protocol] INFO: rcv'd message type=1

I know this is off topic, just thought since I had your attention… :slight_smile:

Are you using Particle Workbench?
Or are you looking for something like this

You can filter the Log level
See here

oops… yes, particle work bench

With Workbench you may want to read this (the forum search feature here does work :wink: but needs to be used too)

1 Like