Argon breathes cyan but can't be signaled nor flashed

argon
Tags: #<Tag:0x00007f1cae095980>

#1

My Argon breathes cyan but cannot be reached. The web ide shows that it’s connected and even lets me “flash” the Argon and says it’s successful, but the Argon is not actually being flashed. It just keeps breathing cyan and doesn’t load any firmware. I’ve tried signaling it, but that doesn’t work either. Every once and a while the Argon starts flashing green, then goes back to breathing cyan or else flashes the multiple colors (while I’m not signaling it). I’ve tried Particle Device Doctor over serial/usb, and it claims to have flashed the Argon with Tinker, but I tried accessing the Argon via the Particle app on my iPad and the Argon is still unreachable. It seems like I’m locked out of my Argon and I have no idea how to get back in. Any help would be greatly appreciated.


#2

Your code is probably starving the cloud process from processing time (e.g. long delays).
Try putting the device in Safe Mode and then flash OTA again.


#3

I have been experiencing a very similar situation. After many, many emails back and forth with Dave at support, some issue with rc27 was found. Details not totally understood by myself. The solution should, so the emails lead me to believe, be included in rc28. Which by the way now is slated to be named 0.9.0rc or similar. Dave said in a perfect world of internal testing we might see this as soon as the 19th. But if it does not work as planned it may be delayed.

I started my support emails on about Jan 10th. And agreed to wait for the next release on about Feb 12.

I hope all is going well with internal testing


#4

Yes, the fix will be in what we’re now calling 0.9.0. AFAIK testing is going well, and it’s possible that it will be released today.

Here is the Github pull request, it has a tiny bit of information on what the problem was.


#5

re: Putting it in safe mode.
Thank you for your help. I’ve tried to put it in safe mode (magenta) but it won’t stay there. It immediately goes into listening (flashing blue) mode.


#6

Re: rc28
Thanks so much for the encouraging news. Looking forward to rc28 solving the issue. One question though: since I cannot connect to the cloud ide nor put the device in listening mode (flashing magenta), how will I update my Argon to the new operating system?


Having trouble adding Xenons to mesh network
#7

You will have to use the command line interface. It is kind of a pain to get all the ducks installed but luckily it is mostly a copy paste activity.

Search for DFU install


#8

You’ll need to install the CLI tool . It’s really powerful and does a lot more than just allow you to flash code either OTA or via USB.

Once 0.9.0 is out, you’ll want to do this:

  • download the 0.9.0 system, Tinker, and bootloader .bin files for the Argon from the repo
  • put the Argon into DFU mode
  • at a command prompt, cd to the download directory and do these:
  • particle flash --usb system-part1-0.9.0-argon.bin
  • particle flash --usb tinker-0.9.0-argon.bin
  • Now, put the Argon into Listening mode and
  • particle flash --serial bootloader-0.9.0-argon.bin

Hopefully after that, you will be Particling happily :sunny:


Having trouble adding Xenons to mesh network
Can't compile 0.9.0 for Argon/Xenon
#9

Will do. Thanks!


#10

Thank you! That worked great. My Argon is back on line and works with Tinker again.
One quick question: What’s the easiest way to take the Argon out of listening mode (flashing blue)?


#11

Reset it. Note that without wifi creds, it will always come up in Listening mode.


#12

0.9.0 has not changed my argon problems. Still does not respond to commands from web or app. I can flash with the cli but once tinker is flashed via the cli nothing can be done. Still claims to be flashed via the web but no actual flash happens.

I have replied to my original help email string with Dave.


#13

I’m sorry it’s not working for you. I followed the instructions above (flashing with cli) which ended with the Argon flashing blue. I then used the particle app on my Ipad to “add a new device” which had me scan the label and go through some steps to get wifi setup. Only then did my Argon start breathing cyan again. It was then accessible via tinker and also the web ide. I wish I knew more and could be of some real help.


#14

I have done all of those things.

It eventually will breath cyan.

It is not able to be signaled from the web or app

Online console shows it is having issues when diagnotics are run. Unfortunately it does not explain what the trouble is.

I will wait for an email reply from support and see if they can glean more I For on the problem from their end.


split this topic #15

2 posts were merged into an existing topic: Can’t compile 0.9.0 for Argon/Xenon


#16

The 0.9.0 update has not solved my problems. Still takes a long time to settle in to a breathing cyan. Then the unit does not respond to any input/control requests from ios app or webpage.

I can not signal the Argon.
I can not flash OTA
I can not use tinker via the IOS app.

Support email ticket number 74327 (original and since closed ticket 73260)


#17

Folks, I learned something yesterday. The step I listed for particle flash --serial bootloader-0.9.0-argon.bin is unnecessary. The Bootloader is built into system-part1-0.9.0-***on.bin.


#18

Hey – if you put the device into Safe mode, can you ping/Signal the Argon?


#19

Nope.

After buttons for safe mode.

Argon went through 3 or 4 sets of fast blinking cyan followed by a single red, then repeated.

Unable to signal from web or iOS

web says device online

IOS says device off line.


#20

Currently. The console shows the argon is healthy via diagnostics.

Argon was breathing.

Ping says it fails

00%20AM

Signal claims to be signaling, but never does.

Feeling more and more like this Argon is defective and not acting correctly.