Argon flashing cyan but not reachable

Hi, I have a student with a new Argon that was working fine for a few weeks. All of the sudden it is now breathing cyan, but whenever they try to do something (flash a sketch, query a variable, etc) it shows as unreachable. If they flash a new schedule immediately upon breathing cyan, it works but then disconnects. I don’t think it’s the sketch because it happens after flashing Tinker and not just their sketch. We’ve tried reinstalling the os, both version 2.0.1 and 3.0.0.-rc.1 with the same results. We can access it via usb, but cannot do anything regarding the cloud. They have also tried unclaiming it and reclaiming it with the same results. The console shows it connected initially, but then they can’t do anything with it using the cloud (flash a sketch, call a function, etc.). I’ve looked at other related topics that are older and they are either slightly different or what was suggested didn’t work (that was where the unclaim/claim attempt came from).

What does happen when trying it in Safe Mode?

It would work briefly, then have the same problem. I think I figured out the problem. The student had a sensor plugged in and the pins were wrong so it was crashing the sketch. It would get cleared out when flashing Tinker but then would crash again when flashing the sketch they were trying to use.

1 Like

Just to clarify then

runs contrary to this earlier statement

While Tinker was on the device, the device worked as expected and only after flashing the student’s code the issue turned up again.
This would be a clear indication for the cause being the code, right?

Not easy to assist when not presented with the entire story :wink:

It was happening with Tinker on there too. It would stay connected briefly then disconnect. It wasn’t until I updated to 3.0.0-rc-1 then back to 2.0.1, reflashed Tinker and things seemed to be working, so I flashed a couple of other sketches but pulled the pins out of the breadboard for the sensor and it seemed to be working then. That’s what led me to the pins being misconnected and sketches getting bad input or something else causing it to crash. I’ve had issues in the past leaving sensors connected when flashing new sketches causing crashes, so I should have asked if they had pins still plugged in. :blush:

1 Like