Can't flash to my Argon!

I posted this in what seems an archived part of the forum, not sure where to put it so please move if in wrong section.

I’m having issues with my Argon, was following the webhook tutorial (https://docs.particle.io/tutorials/device-cloud/webhooks/), I flashed the example webhook firmware code and have been unable to flash anything else to the device since. Not sure if it’s related to the delay() calls?

I’ve tried resetting it, putting it into safe mode (it ends up exiting safemode by itself and running the webhook code). I’ve reclaimed the device (just in case), I’ve tried the cli hoping I could flash it via usb (but seems you can only flash via cloud, which times out just like the WebIDE).

Not sure what else to do, please help!

This might be baby steps however - have you tried to re set it up using the app? - This makes sure it can connect to your local wifi?

Then once it restarts - does it breathe cyan?

Thanks for the reply. Yes I tried setting it up from scratch, but it retains the webhook firmware.

Basically on start/restart it goes through the normal motion, it flashes green, cyan, then breathes cyan whilst the webhook code runs (which turns the onboard LED on and off), I can also see the events are still being generated.

If I put it into safemode, it initially flashes green, cyan and then breathes pink. After a minute or so it flashes green, then cyan and goes back to running the webhook firmware.

Does it appear in the WEBIDE? in bottom right ?

image

if so and you click the exclamation mark - does the argon cycle the colours?

Yes it shows, as you can see I get updates from the events, although clicking the exclamation mark only makes the colours in the WEBIDE cycle, the argon keeps breathing cyan. Forgot to say, it also goes from breathing cyan to flashing cyan like it’s trying to get a connection to the cloud server.

Untitled-1

As I’m typing this it’s flashing cyan and occasionally showing three orange flashes then back to flashing cyan.

It’s now showing as offline with no updates.

The delay(30000) in the webhook sample is counter productive when it comes to OTA updates.

Put your device in DFU Mode (blinking yellow) and run particle flash --usb tinker -v.

It flashes tinker but it’s still not responding to WEBIDE or console.

It goes from breathing cyan, to flashing cyan. Regardless I can’t ping or signal it.

Untitled-1

I’ve left it plugged in for the last 10 minutes here’s the activity if at all helpful:

can you also do a particle update-cli - your version numbers of the DFU util seems to be older than mine?

Untitled-1

I also flashed tinker as before, output was exactly the same.

Yay, finally responding! Thanks guys I really appreciate the help.

Now I’m not sure this is related, but I deleted my integration test before trying to signal the argon in the console.

1 Like

Unfortunately I’m back it’s doing it again. Not responding to flash, etc. :frowning:

I don’t have any integrations, I’ve reset it, updated it, flashed tinker, Ive now unclaimed it too but it starts flashing cyan and is uncontactable.

I’ve left it for a while now it’s blinking cyan slower (before it was quick) and every so often it flashes orange 3 times.

Is there any way to fully factory reset it?

You should see a response to your ticket :slight_smile: