Argon is blinking blue but not connecting to internet or CLI via usb

Hello,

My particle argon is bilking blue and not connecting to internet. I tried to connect it with pc via USB but windows 10 say it is not recognized. I tried to update drivers and windows 10 says “Best drivers are already installed?”

Particle CLI is not detecting it, Even after putting the device into DFU mode. Other argon device is working fine.

please see this 35 secs video. https://photos.app.goo.gl/pFoDqoaU1HQW9VSu9

[https://photos.app.goo.gl/pFoDqoaU1HQW9VSu9]

Sorry, can not upload video directly in this form. So please visit the link.

Please help me to solve this issue. Thanks in advance.

I would try configuring your device by using Particle app on your phone. Here is a link:

https://docs.particle.io/quickstart/argon/

Thank you very much

It was able to connect to cloud and I was able to flash new code. But still it is not recognized in CLI.

Even when Windows DevMgr tells you that you got the best drivers already installed, that info may not really be true.
If Windows “misinterprets” what kind of device it is it will only look for the most recent drivers for the wrong device but not for the correct ones.

You need to investigate which drivers Windows chose and possibly give it a nudge to take another :wink:

A screenshot (not a video) of DevMgr with the relevant driver details might be helpful.

1 Like