Initial setup of Argon fails

When doing a setup for my particle Argon I have only run into problems.
I only received my Argon yesterday as part of the air quality kit.
I try to set up and I only get:
It appears as though you are already logged in as xxxx@yyyy.com?
Would you like to use this account? Yes

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

C:\users\xxxxxx\appdata\local\particle\bin>
and yes, I am connected to the internet. I have in a host based firewall, but I do not know what ports to put an exception for, so I put an exception for the particle.exe application.
Yes, the led is flashing blue for the setup. I can get a device list when I set it up for DFU mode. I can apparently connect to my wifi when using putty an manually entering wifi setup commands with “w”.

Device type: Core, Photon, P1, Electron , etc…
Argon
Firmware version installed on the device
Using “particle serial identify”
Your device id is e00fce687a8cb8xxxxxxb596
Your system firmware version is 1.4.4
Firmware flashed from: Build, Dev, CLI, make
CLI: “particle update”
Firmware source code, or relevant parts if it’s large
None: this is the initial setup
Steps to reproduce the issue
“particle setup”
Steps you’ve already tried to circumvent the issue
I downloaded CLI form Particle. Version 2.2.0
I tried using the android app on my Samsung S3 tablet and no joy there either.
The image of the code on the device is clear and stable for my camera,
but there is nothing else
The device when attached to my Windows 10 laptop shows as
“Argon Serial (COM6)”
As indicated above the command “particle serial identify” works fine:
Your device id is e00fce687a8cb8xxxxxxb596
Your system firmware version is 1.4.4

I am trying to do the initial setup so that when I do a "particle list" the device will show up.