Xenon blinking red (10)

after flashing a wrong firmware code(my code) Xenon go in listening mode so I following the instruction how to set up using USB.
particle flash --usb xenon-system-part1@1.2.1.bin
particle flash --usb xenon-tinker@1.2.1.bin
after flash the tinker Xenon go in SOS 10 blinking red

I search in the community and i find this so I’m flash with this code:
particle flash --usb xenon-system-part1@1.2.1-rc.1.bin

No result my Xenon continue flashing red.
Thanks Valentino

Try this first


That will reset the device to a known state, then test with tinker to make sure its OK and then retry your code

Hello thanks now is blinking blu (listening mode) but I’m unable to go out of this situation.
This Xenon was configure in a mesh network to a Boron GW.
Thanks for any suggestion.

@ScruffR - can you comment here?

If you don’t already have it, install the Particle CLI. Then, connect the Xenon to your machine and try to do

particle usb start-listening
particle serial inspect

If that works, report the “inspect” results here.

If it doesn’t work, grab the 1.2.1 bootloader .bin file from the Github repo and do

particle usb start-listening
particle flash --serial <1.2.1 bootloader file name.bin>

Hello this is the result from the suggested command.
Thanks Valentino

C:\Users\valentino>particle usb start-listening

C:\Users\valentino>particle serial inspect
Platform: 14 - Xenon
Bootloader module #0 - version 500, main location, 49152 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
System module #1 - version 1401, main location, 671744 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
Bootloader module #0 - version 401
Radio stack module #0 - version 202
User module #1 - version 5, main location, 131072 bytes max size
UUID: 1694D20EB67860398244AB56B1D6E8C7D22E0CDFB62F8B7DA7FD7CC13539CC91
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
System module #1 - version 326
Radio stack module #0 - version 202, main location, 192512 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS

Hello after the two command below not result Xenon continue to blinking blue
Thanks Valentino

particle usb start-listening
particle flash --serial xenon-bootloader@1.2.1-rc.1.bin
! PROTIP: Hold the SETUP button on your device until it blinks blue!
? Press ENTER when your device is blinking BLUE
sending file: xenon-bootloader@1.2.1-rc.1.bin
Flash success!
Flash success!

Bootloader version 500 is the most recent.

particle flash --serial xenon-bootloader@1.2.1-rc.1.bin

would downgrade the bootloader.

I’d run this sequence

particle flash --usb tinker -v
particle update -v
particle mesh list
particle mesh add <xenonID> <gatewayID>

Make sure your gateway can connect to the cloud before running the add command and then have both devices connected via USB to the computer you are running the command from.

Sorry just a question if I run the sequence this will do in both device correct?

Most importantly I’d do that for the Xenon, but you can run the first two for the gateway just the same.

I had an error in the second one before (now corrected).

Hello so I run the first two command and this is the last row of particle update-v
but my Xenon stay in listening mode (blinking blue). If I run the particle mesh list I have both on the list Xenon and Boron.

Transitioning to dfuMANIFEST state
File too short for DFU suffix
A valid DFU suffix will be required in a future dfu-util release!!!
Cannot open DFU device 2b04:d00e
! System firmware update successfully completed!

Your device should now restart automatically.

Do you have a blank between update and -v as in my post above?

Did you also run the last command?

This should be with blank
…\Spark>particle update -v
and this is the answer after add xenon to mesh network
The device is already a member of the network

Is your Xenon still blinking blue?
If so, you could try creating a new network with your gateway and add that Xenon to that new one.

Hello good news this work Xenon is again alive in a new mesh network
Grazie mille! e buona giornata

1 Like

ScruffR only for info I disconnect the Xenon from the power (usb) and reconnect to another power source and after Xenon blinking blu. This afternoon I try to rebuild a mesh network and leave a msg.

Ok so I made two test connect and reconnect to the power source each time Xenon go in blinking blue, both test I use the command particle mesh remove and particle mesh add.
Do you suggestion while the disconnect from power source lost the connection with the Gateway and only with the two operation above the Xenon reconnect to the mesh network?
Probably I connect the Xenon to a battery so I use as work around.
All best Valentino

The connection settings should definetly not be lost when even when depowering the device.

If this is happening each time with 1.4.0 and Tinker running on both devices it’s probably best to file a support ticket

Thanks for your help I post the problem at support.

I’ll be working on your support ticket today, @Tino52!

If our conversations sheds light on some new best troubleshooting practice, I will make the results visible here.

1 Like