Xenon - Recover from DFU Mode

I deployed a bad script to my Xenon, that got it to Red Flash SOS mode. I am able to get it back to DFU mode.

How do I recover the Xenon back to normal from here?

I have tried particle doctor however that only returns -

? Select Continue when ready Continue
The Doctor didn't complete successfully. Error writing firmware: file does not exist and no known app found.
> Please visit our community forums for help with this error:
https://community.particle.io/

Have you tried particle flash --usb tinker -v while the device was in DFU Mode?

I just tried, and that returns it to flashing red.

I have tried to manually flash the firmware & tinker (I think that is what ^ does as well?) and that didn’t resolve it either.

particle flash --usb xenon-system-part1\@1.2.1.bin 
particle flash --usb xenon-tinker\@1.2.1.bin 

UPDATE:

I’ve run particle update a few times against it. The last time got it to blinking blue.

I went back and

  • put it in DFU Mode
  • particle update
  • particle flash --usb tinker -v

And that seemed to get it back.

For future info, the bit you missed was flashing the bootloader.
particle flash --serial "xenon-bootloader@1.2.1.bin"

I just do this all the time because I have found it avoids the problems you have experienced.

1 Like