Xenon permanent rapid flashing green


#1

I have an Argon and Xenon and have been using them together successfully for quite a while. OS 1.4.2 was installed with SYSTEM_MODE(AUTOMATIC) and no thread enabled.

Flashing GREEN rapidly began a couple of weeks ago and I have tried many suggestions from others I read from this Particle community resource. At this point, I would like to be able to set this device to factory settings and pair it up again with the Argon. Start from scratch. I am failing to make the Xenon flash BLUE. Thanks for any suggestions you might have to accomplish this.

Recently, tried “particle update” while in DFU mode several times and then downloading tinker but still resulting with rapid flashing GREEN on reset or power cycle with device showing offline in app.

Below is the command and response for flashing tinker:

particle flash --usb tinker -v
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device…
ID 2b04:d00e
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0 …
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash "
Downloading to address = 0x000d4000, size = 11012
Download [=========================] 100% 11012 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state

Flash success!


#2

I would perform a factory reset on it, instructions here: https://docs.particle.io/tutorials/device-os/led/xenon/

According to the docs, there is no user firmware stored from the factory so you’ll need to flash tinker after setting up the device.


#3

Happy Thanksgiving! And, thanks for your help! I went ahead and performed the factory reset and flashed tinker to my Xenon. After that, I was able to flash blue for further config.

It turns out, the rapid flashing green was resulting from “something gone wrong” (more below) with my mesh network. My Xenon was dropped from the mesh network and I could not add it back in. So, I needed to remove all devices from current mesh network (just one left, my Argon) and create a new mesh network. Then, add my Argon and Xenon via CLI (did not have success doing this thru the app). All this I accomplished after reading the topic: Remove mesh network

More about “something gone wrong”. I had upgraded to the new Mac OS Catalina where I changed from bash: to zsh: then back again, now staying with bash:. I think this flip/flop caused issues with Visual Studio Code app. And, perhaps, hosed my mesh network, somehow (probably, not so, but I DID make a frustrating mess). Once I was able to settle down VSC app use over the course of a few days I posted for help with something concrete at issue.

In retrospect, when things went bad, I remember the Argon was waiting FOREVER in a waitUntil(Mesh.ready) statement. Both the Xenon and Argon were indicating they could NOT access the mesh network. If I was smart, I would have started investigating right there! Oye!

I am reassured to know I can get these devices back to factory settings. I needed that little push. Thanks, again!