Unable to connect photon to another wifi

Hi, I connected my photon to the wifi for a first time via the setup page https://setup.particle.io/ and it worked successfully.

Now I want to work over another wifi and I tried to run the script from the page again and it’s not working (the LED stay green) I also tried the

sudo particle serial wifi

command via my linux system but It stuck at

Select the Wi-Fi network with which you wish to connect your device:.

Has your computer got a WiFi connection and is it using it while you try above?
I’d also avoid all automatic scanning and rather enter SSID and security type manually.
If your Argon is running rc.26+ you can also use a standard serial terminal program to send w to the Argon in Listening Mode and enter the WiFi credentials this way.

Am with @scruffr here, set up the Photon manually by entering listening mode (blinking dark blue) and connect to it serially via USB from your Linux host using the inbuilt “screen” command, eg something like:

screen /dev/ttyUSB0

  • pressing the “i” key should display the device id;
  • pressing the “s” key (or it could be “w” ?) will enter the wifi setup function.

I’ve tried and nothing seem to work, even my old wifi doesn’t work now. I also tried to hold the setup button 10 seconds to reset the wifi credential and the device doctor failed after asking for the type of antenna.

Can you connect to the wifi with your mobile phone at least?

Is the wifi set to use the 2.4ghz band?

Suggest entering safe mode (ie your app is not run), can you connect then?

I don’t have a cellphone (I broke it :frowning: )

the wifi is 2.4Ghz

I’m not able to enter in safe mode and I don’t think it’s possible in that state because

“Before entering safe mode, the Photon will proceed through the normal steps of connecting to the cloud; blinking green, blinking cyan, and fast blinking cyan. If you’re unable to connect to the cloud, you won’t be able to enter safe mode.” (https://docs.particle.io/tutorials/device-os/led/photon/)

You can still enter Safe Mode, you may just not arrive at the final state of breathing magenta.
But once you engaged Safe Mode, you can then (while still trying to connect) enter Safe Listening Mode by holding down SETUP till you blinking blue starts.

BTW, entering WiFi credentials does not require you to go through the particle doctor procedure, just particle serial wifi should suffice (and don't get tempted by any of the auto detect features :wink: )

I've clarified that part in the docs too, should be online soon.

I did it and this time (Dunno if it’s my eye but I felt like the lower side of the led was red and the upper was magenta),
After doing the particle serial wifi the led blinked cyan and then it came back to safe mode

Nope, not your eyes, but that's how RGB LEDs work.
You have three sub-LEDs (red, green, blue) and magenta is made up of red + blue.

That suggests that your device has some incompatible application firmware on it.
You can post the output of particle serial inspect (in Listening Mode) to see what's wrong.
Or you just reflash system and application as described here