Can't get photon to connect via USB

Yes, I tried connecting the photon multiple times with my smartphone, but I got the message:

Setup process couldn’t configure the Wi-Fi credentials for your photon. please try running setup again after resetting your Photon and putting it back in blinking blue listen mode if needed.

So now I am trying to connect via USB, and I am still running into problems, I installed node.js, and I ran the command prompt, but I get this message:

 I have detected a Photon connected via USB.
 Would you like to continue with this one? Yes
 The Photon supports secure Wi-Fi setup. We'll try that first.

 PROTIP: Wireless setup of Photons works like a wizard!
 PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
 PROTIP: You will lose your connection to the internet periodically.

 No nearby Photons detected. Try the `particle.js help` command for more information.
 Would you like to wait and monitor for Photons entering setup mode? (Y/n)

So yeah, idk what to do.

Try doing particle serial wifi since particle setup is trying to do this wirelessly first, where you may encounter the same issue that’s preventing you to connect with your cellphone, whatever reason that might be.

Well, now look at my problem:

C:\Users\admin>particle serial wifi
? Should I scan for nearby Wi-Fi networks? (Y/n) Y
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: xxxxxxxxx
? Security Type WPA2
? Wi-Fi Password xxxxxxx
Done! Your device should now restart.

C:\Users\admin>particle device add xxxxxxxxxxxxxxxxxxxxxxxxxxx
You're not logged in. Please login using particle cloud login before using this command

C:\Users\admin>particle cloud login
? Please enter your email address xxxxxxxxxxxxxxxxxxxxxxxxx
? Please enter your password *********
> Successfully completed login!

C:\Users\admin>particle device add xxxxxxxxxxxxxxxxxxxxxxxxxx
You're not logged in. Please login using particle cloud login before using this command

That’s odd but shouldn’t stop you from claiming your device.

Does the device get connected to the cloud at least?
If so go to and add the device via the target drawer.

But for the not staying logged in thing: Are you running all these command in the same console session?
What version node and particle-cli have you got installed?

No, the Photon does not get connected to the cloud. It just keeps doing that blue blinking. If I push reset it just keeps doing that green blinking.

Yes I am running all these commands in the same console session. I just downloaded the new node. I am just using the regular command prompt. Is that ok or no?

OK, then let’s try another route.
What OS are you using?
If Windows pre 10, you might need to install drivers.
Can you see the Photon as COM device in Device Manager?

Once you can access the devices serial interface:

  1. wipe any stored credentials by holding SETUP for 10+ sec till rapid flashing blue.
  2. open a serial terminal program like PuTTY and connect to the Photon
  3. send w
  4. enter SSID
  5. select encryption scheme
  6. enter password
  7. wait and see

Now (maybe after a reset) you should see your device getting to breathing cyan.

If not there might be other issues with your network, SSID, power supply, router, … which we haven’t discussed yet
Check these too