Photon setup issues

Hi Guys

Just got my new Photon delivered today (very exciting) but I cant for the life of me connect to it in any way. Following the setup guide I plugged it in via USB and held the setup button until it flashed blue (sidenote: I did have to press reset after holding setup for about 20 seconds of nothing changing to get it to flash blue), and that is all it has done since.

I installed the android app but it couldn’t find the device it so I went down the CLI route but it was unable to find the Photon via USB and when trying to connect to it via wifi it threw an error:

! Woops. Something went wrong connecting to Photon-8UVQ. Please manually re-connect to your Wi-Fi network.

I tried running cmd and powershell as an administrator but got the same result.

Any help would be much appreciated!

Do this:

  • place Photon in Listening mode
  • particle setup

I also strongly suggest upgrading your system firmware to the latest using DFU https://github.com/spark/firmware/releases/tag/v0.4.1

Hi Kenneth, this is connecting to it using the node-js package right? I tried that but at the stage it tries to find devices connected by USB it comes back with a message that no devices were found. Then it tries to scan for wifi devices, finds it but is unable to connect.

@yardbird,

did you install DFU-util? We can use that to attempt to fix it as @mdma suggested :smile:

HI Kenneth

I Installed the update using dfu-util (I assume it was successful as it went from flashing yellow to flashing blue light and went from appearing in device manager as a DFU device to a COM4 one) but it still exhibits all the behavior described above :confused:

Im trying to flash the user-part.bin file but im not sure it will get anywhere seeing as i cant connect it to the cloud

(Continuing from PM…)

Could you please update particle-cli by running

npm update -g particle-cli

And then install the USB driver if not already done.

Alas, the Wizard Wi-Fi setup is presently not available on Windows (Known Issues), which leaves manual setup by answering “No” to the first question.

I’m puzzled why the Android app doesn’t find the Photon. (cc: @ido, @jensck) but I hope with the manual WiFI setup you can make progress.

Let me know how it goes! :smile:

The driver is already installed and particle-cli is up to date.

When answering no to the first question that just finishes the dialogue after it decides there are no USB devices

Setup is easy! Let’s get started…
It appears as though you are already logged in as emailaddress
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

No devices detected via USB.
? Would you like to scan for nearby Photons in Wi-Fi setup mode? No
Goodbye!

Can you check your USB cable, such as trying a different one? I’ve seen a few times that USB Serial fails due to a bad cable.

Can you confirm the Photon appears in Device Manager under Ports? If not there, it might be under USB Devices as an unknown device.

Yes it is under ports as Photon (COM4). i have tried on 2 different cables on 3 different ports, its currently plugged in as directly as i can get it

Could you download PuTTY and try connecting the terminal to COM4.

As always, in listening mode (blinking blue.) Once connected, you should be able to press ‘i’ and see the device ID, and then ‘w’ to setup WiFi.

Happy to provide more guidance on using PuTTY if needed.

I think that might have done it! breathing cyan and able to flash to it!

Thank you for all your help @mdma!

WOOHOO! Great news!

@yardbird you mentioned that you couldn’t get the Android app to see the Photon when it was in listening mode. When in that mode, does the Photon soft AP show up in the list of visible access points on your computer?

yes i could see it as an unsecured wifi connection

Hello, sorry to dig up an old topic, but i have the exact same problem. Following the recommended command, i managed to connect (through putty) the Photon to my wifi, I get the breathing cyan led. That’s good but how do I claim the device in the web interface to be linked with my account ?

First, this: https://docs.particle.io/faq/particle-devices/finding-device-id/photon/

Then either this:
https://docs.particle.io/reference/cli/#particle-device-add
or the giant “add device” button in the web IDE.

Arg, I was looking for the giant button in the dashboard. I did not think about the IDE. Thank you :slight_smile: I found it, and it worked perfectly

1 Like

Where do you do this setup? I’m trying to figure out how to fix this issue for myself.

It’s a command for the CLI, though I personally prefer particle serial wifi, though you;ll have to claim it manually afterwards, if you choose to go that route.