Photon setup issues

Hi, my photon was working fine, and suddenly it started to blink blue (slowly), Now I can´t connect it neither by wifi nor by usb

Have you tried Safe Mode?
If it keeps blinking blue in Safe Mode the WiFi credentials need to be reapplied.

Hi, it worked. I reconfigured later using CLI.


I just got my photon and I can’t get the setup working for the life of me. Errors range from “TCP socket timed out” to being stuck on the “obtaining device information” message to “Can’t connect to the cloud”.

  1. My wifi security is WPA2 PSK/Personal. But that option doesn’t show up when I enter my wifi information manually. What option should I choose instead?
  2. Having the photon scan for wifi networks leads to annoying TCP socket timed out errors.
  3. My wifi is 2.4 GHz
  4. Attempting to enter the network information manually leads to the repeating “obtaining device information” error
  5. If I miraculously somehow connect to the internet with the photon, then I get stuck on the “can’t connect to cloud” error.
  6. Instead of using “particle setup”, using “particle serial wifi” has the networking scanning feature actually work correctly and no socket error messages. But I don’t know how to go from this to connecting my device to the cloud and adding my device to my account.
  7. I just now tried using the mobile app version to set it up, but even with that I also got an error. "internal problem with the device. I’m going to try resetting it to see if that fixes it.
  8. One more try of the mobile app, it failed again at that “waiting for device cloud connection” step. I wonder if my board is faulty… also does this require any port forwarding?
  9. I’m trying to update the photon’s firmware, but I keep getting this error “An error occurred while attempting to update the system firmware of your device: File too short for DFU suffix
    A valid DFU suffix will be required in a future dfu-util release!!!
    Error during download get_status”
  10. I tried to force the firmware update manually and now the photon is stuck immediately blinking yellow and I can’t leave it.