[SOLVED] Photon Initial Setup Issues

I just took my photon out of the box today and have been trying to get it setup, but have been having issues getting it to connect to the Android App and to my computer via USB. I went through the Windows 10 Full CLI and DFU Setup at the following link ([Particle Official] Windows 10 Full CLI and DFU Setup) and I believe I received the correct results as the screenshot at the end of the tutorial is identical to my device manager- a screenshot of my device manager is below.

I then moved onto using the CLI to setup the Photon. I put it in “Listening Mode” so the light is flashing blue. When I get to the end of the process below I will reconfigure and go through the same process yielding the same result. The light does not change color at all during this, it continues to flash blue.

I am running Windows 10 on my computer.

I am not sure what is going on, any help would be greatly appreciated.


Could you give ‘particle update’ a shot while in DFU mode? Then, in listening mode, try ‘particle serial wifi’ and follow those steps. Once/if that connects place it in listening mode again and issue ‘particle identify’ and copy the resulting ID. Hit reset and wait until it’s breathing cyan again, after which you can issue ‘particle device add [ID]’.

Looks harder than it is :wink:

Thanks for the quick response Moors7!

I tried ‘particle update’ this twice this morning. The first time I was unsuccessful, you can see the window below.

I unplugged the Photon and tried again. This time I was able to update and at the end the Photon changed from DFU mode to listening mode on its own, but was not able to run through ‘particle serial wifi’. Here are the results below.

Could you make sure the device is properly into listening mode (reset, and put it there manually if it doesn’t do so automatically. It might also be worthwhile trying a different USB cable/port to see if that migh cause issues. USB 3 has been problematic in some cases.

I tried 2 different USB 3.0 ports and 1 USB 2.0 port resetting the unit each time and ensure it is into listening mode, I also tired two different USB cables. It yielded the same results I saw before.

Ok, so it looks like your next set is to configure your Photon such that it connects to your WiFi router.

Put your Photon in Listen mode (blue light flashing)
Use the CLI and type

particle setup wifi

and follow instructions (provide SSIS, and password). Once done and the Photon connects to your WiFi router, it should breadth green and almost instantly change to breathing cyan (connected to Particle cloud)

In Device Manager, do you see (under Ports (COM & LPT)), your Photon as a specific COM port?

Thanks for the help shiv. In response to your first reply when i try ‘particle setup wifi’ comes back with the message below.

In my device manager the Photon is showing up as USB device, it is not under Ports (COM&LPT). Here is a screenshot of my device manager. You can see the Photon below.

Ok, I think you’ve missing the USB driver. You need to install the USB driver. You can download it here. Particle USB Driver for Windows

I followed the link and when I tired to install the driver I got the message below

I exited the window and moved onto the next steps in the tutorial which had me type ‘npm install -g particle-cli’ below is the following result in my command prompt

That looks like you now have the Particle CLI installed. So if you didn’t have it installed previously, I’m not sure how were able to execute the
particle xxxx

Photons have always shown up (for me) under the Ports (COM & LPT) section unless they are in DFU mode (Flashing Yellow). I’m also on Windows 10 and my driver is signed by Spark Labs Inc. (the original name of Particle).

I had gone through the driver install in the past, but did it again after you recommended just to be safe. I just tried ‘particle serial wifi’ I still received the same error message.

Yea, you need to see the Photon as a COM port. I think, possibly, the USB cables you’re using are “Charging” cables and not “Data” cables.

I have tried a couple of different USB cables along with the cable that came in my kit. Is there a good way to tell a data vs charging cable? Is the cable going to set this is a COM port? I would assume I would have to change something elsewhere, is that correct?

The cable from the kit should be fine. It would be the proper cable. It’s just that a lot of USB cables are for charging only and there is no easy way to tell.

With the right cable, the device (Photon) will be seen as a Serial device and will show up as a COM port. Cameras, Phones, external hard drives etc. that are connected via USB will show up under the Universal Serial Bus Controllers/Devices section. The device determines where it shows up, provided the drivers for the device are installed. When the Photon is in DFU mode it will show up under the Universal Serial Bus Devices section (like yours does). The same Photon, when not in DFU mode will appear/show up in the Ports (COM & LPT) section.

Do you hear the typical sound from the OS when you plug/unplug your device? Maybe you should try installing the driver manually?

  1. Right click on the Photon in Device Manager
  2. Choose Update Driver Software
  3. Choose Browse my Computer
  4. In the “Search for driver software in this location” field, browse to the folder where you’ve downloaded (and unzipped) the Particle Windows Serial Drivers and follow prompts from that point and eventually close all dialog windows.

When I unplug and plug the device in it makes the usual sound from the OS. I grabbed the drivers from the link you sent earlier, extracted and installed as you instructed, and it says that my drivers are up to date.

Is the Photon showing up under the Ports section in Device Manager?

No, its under USB devices.

I’m sorry, I’m at a loss. Unless the Photon shows up under the Ports section you’re not going to be able to use the Particle CLI to set up the device.

Maybe @Moors7, @ScruffR or @peekay123 can help.

No problem shiv, I really appreciate the help! Great help from @shiv!