Problem with photon - blinking blue but can't setup

Hello,

I have been using my photon for a while. I wrote a program to monitor 2 temperature sensors and post the temperature to the cloud. … But that’s not my problem

Yesterday, right out of the blue, I stopped receiving data from my Photon. I tried a few things and I can put it in setup mode (blinking blue) but the phone app didn’t pick it up.
Here is what I tried:

  • Phone/tablet app to setup new device. No go. Did not find a photon. No Photon-xxx network found.
  • particle setup on windows in admin mode (using the particle CLI) - logged in account, found photon attached to USB, scan for network, select network, select WPA2, after a while I get “Potentially unhandled rejection [3] Serial timed out (WARNING: non-Error used)”
  • terminal connection to the serial port where the photon is recognized (used TetraTerm). “i” command works, returns the device id. Try to setup the wifi through that so issue “w” command, get SSID prompt, enter SSID, then get encryption prompt and I select “3” (WPA2) and the terminal does not come back with an answer.

What do I so.
I already lost my first Photon that now after probably 1 year is just stuck on solid blue light. Before it was doing the SOS red light.

Help.
Thank you
Vlad

  • Which firmware is on the Photon running?
  • Did you run the lastest CLI version?
  • Is an USB-Hub between PC-Port and your Photon?
  • Did you give particle setup doctor in CLI a try?

Which firmware is on the Photon running?

Don’t know. Since it worked until yesterday, guessing the latest if it updated it self

Did you run the lastest CLI version?

Yes. I just did an update and it updated without errors

Is an USB-Hub between PC-Port and your Photon?

It is on a port directly in the PC

Did you give particle setup doctor in CLI a try?

Just did. Same result. Same message

… Just tried it through a hub, same message.

Tried the particle device doctor. The message said the firmware updated but I get same result

Lots of messages, I know …
When the device is in setup mode (blinking blue) I can’t find a Photon-XXX network.

Hello,

Anybody can help with this?
My Photon still blinking blue when it wakes up but I can’t see its wifi network.

Help

1 Like

Have you by any chance altered anything on your WiFi AP?
Switch off or rename any 5GHz network.
Clear WiFi credentials.
Flash Tinker to the device via particle flash --usb tinker (in DFU Mode).
Reapply WiFi credentials (wihtout any auto-scanning).
Provide a video of what’s happening during boot-up.

Hello
Here are the answers to your questions ScruffR:
Have you by any chance altered anything on your WiFi AP?

No. Have not changed that since the initial setup years ago

Switch off or rename any 5GHz network.

I have not done that. Are you saying that I should try to do that?

Clear WiFi credentials.

I have tried that

Flash Tinker to the device via particle flash --usb tinker (in DFU Mode).

Yes, I just did a
particle update
and then
particle flash --usb tinker

both in DFU mode. Both look like they worked.

image

Provide a video of what’s happening during boot-up.

I am not quite sure what you would like to see… The blinking patterns of the LED?
I can do that if that’s what you are looking for.

Thank you
Vlad

Yes, I do.

Yes, exatly that.

BTW, a single > is enought to introduce a quote, but actually you’d do it the other way round.
You quote the original question and then state the answer after the quote - as seen in my reply.

Got it.
I will provide what you requested and I will try the quote thing.
Now … got to get to work.
Thank you for your help
Vlad

1 Like

Hello,
I have unplugged my wireless extender and I disabled the 5GHz radio on my router.
I have put my Photon in setup mode (flashing blue) but it still don’t see its wifi network.

Here is a video of the Photon booting up (booting up and flashing green)
https://photos.app.goo.gl/5KNcU9qVHfF49ynm1

Let me know what else would you like me to try
Thank you
Vlad

That’s not what we’d usually think of when we are talking about blinking blue (although 9 seconds is a bit short to properly tell what’s going on).

The blue your video shows is the D7 LED, but with your previous description we’d rather have expected the RGB LED in the middle to turn blinking blue (as it would be in Listening Mode or without WiFi credentials).

This looks much more like an issue with your external circuitry causing a crash/reset.

Take the device out of the board and try again.
Another suggestion might be to change the USB cable and/or power supply.

Hello,
Yes, I know about the D7 LED. The video is of the reboot and the device going to blinking green so waiting for network.
I changed the cable and the power supply and I have taken the Photon out of my PCB (I thought about that one before also).
Same results

Vlad

  • Do you have more photons / cores in your wifi and these work as expected?
  • Is your router (which model?) set adding new devices as allowed?

Hello Postler.
I have one more photon that has not been working for a long time and I gave up debugging it since I was not getting anywhere.

My router is a TP‑LINK Archer C50 and I can add new devices to the wifi network. I have added a bunch of etekcity voltron smart outlets about a month ago.

That’s an interesting background info.
Have you checked how many available IP addresses your DHCP server can hand out? Maybe your Photon can’t acquire an IP address due to an exhausted IP address pool.
Can you try to connect your Photon to another WiFi network - e.g. your mobile phone tether?

Not a bad guess ScruffR - didn’t think about that one but no, I don’t have any restrictions on my router and my photon worked until about 1 week ago.
… Also, when you set the photon up, it should start in AP mode and that’s how you connect to it first, right. …
I just don’t see the photon’s network at all.

If you want to get the device back working I’d try to avoid any of that auto-magic stuff that’s supposed to work when everything is going to plan - but in your case it obviously isn’t.

When your Photon has no credentials (e.g. after clearing them as suggested above), the device will startup in Listening Mode (blue blinking RGB LED).
In that mode, I’d either use particle serial wifi or serial command w to enter credentials.
But as we already established there is a problem with your standard WiFi try to connect to another one (e.g. mobile phone hotspot).

If that doesn’t work there might be other reasons (e.g. sticky setting to use external antenna or WiFi.useStaticIP()).
While particle doctor should help there, you can always flash some dedicated application firmware that forces the device into the desired modes.

BTW

Have you checked or did you just not set any restrictions?
For instance I had a Netgear router that had a default limit of 32 DHCP IPs.
When you say 1 week ago it worked, can you remember adding any devices to your network or e.g. setting up a device with a static IP round about that time?

BTW²: I might have missed it, but what system firmware have you got on your device?

Hello,

I have tried to enter the wifi credentials through particle serial wifi.
I get to select the network and then I select the security type and then it times out with: “Something went wrong: Serial timed out”

Have you checked or did you just not set any restrictions?

Yes I have checked. I have mine set for 200 devices.

I have not added any devices before or after my photon stopped working

I have 0.6.3 firmware on the device.