Photon continually blinking blue/ a couple things to eliminate

hello,
i have had my kit for a few months but just found the time to start and so far it is taking way too much time. i have read all the threads i could find via google on the same topic. i have tried usb setup and all i get there is

Obtaining device information…

Obtaining device information…

Obtaining device information…

Obtaining device information…

Obtaining device information…
continuously until i break/escape.
the photon blinks blue just fine
it sees the photon it just does not set it up via usb. the wifi thing is just as frustrating. over the past year this router, a netgear AC1900/c6300BD has picked up everything i have placed in front of it. old and new. I’m almost certain this device is defective. edit: at power up the device goes from white light to blinking blue. there is no green.
EDIT: following this page
http://blog.jongallant.com/2015/08/particle-photon-setup-windows-putty.html
i was able to get a device id, at the step of saving the wifi info the device started to blink green and would go no further. so now when i plug in device i get a continuous blinking green which will go to blinking blue if i hold the setup button for 4 seconds.
edit:by enabling guest network the device has now hooked up but at the same time it is not part of my local network as the guest is seperate. well, at least i know that the device will hook up with the router so for me i need to find out how to get it on the local network. yes, everything has been downloaded tonight so i guess it is all new unless particle keeps old stuff around to download.
update:i turned off guest network, rebooted everything[pc/router/unplug photon] and the when it all was back up photon seems to now be able to connect to the local network. also shows up in build and the android app. so after about 10 hrs of learning all i can say is it seems for some reason i just had to turn on guest and let the device hook up and go through some setup stuff. so yeah, i can add to the issue, try guest network with no security for a first hook up. worked for me.
update: another thing that i learned during the process is i should not think a possible solution will not work for me just because i read earlier posts that the solution did not work for others. i had read several posts from members in other threads that the guest network made no difference so for nearly 7 hours i did not even try it. then i decided i should eliminate it for my situation and in doing so discovered it was exactly what i needed to try because it solved my issue. important fact is that anything i try may not work for others.

Are you using the latest CLI?

  • Place the photon in DFU mode
  • run particle update
  • place the device in Listening mode
  • use particle serial wifi to configure wifi.

Let us know if the Photon managed to be breathing cyan :slight_smile:

I’m trying to help a friend with a brand new Photon. The Particle app will simply not work on his Android phone or my iPhone to connect the Photon to the network and allow it to be added to the account. We’ve tried numerous times, initially getting the same “Obtaining device information…” as shown above. I was then able to run the commands recommended by @kennethlimcp and it seemed to solve the problem of registering the device to the account. It shows up under “particle list”.

HOWEVER, when I try to use the Particle app to connect it to a new (another) WiFi network or simply erase the WiFi credentials and try to connect to the same WiFi, the app stalls at step #2.

I’ve used the app for many Photons and have never witnessed this behavior. I’ve assumed the “particle update” would ensure the OS was replaced with a new copy.

I can compile and download app code, but we need to get past the inability to use the Particle app to get it on new WiFi networks.

Thoughts?

The device number is: 350021000547353138383138 and it’s running 0.4.9.

What version CLI are you using?
What was the output of particle update?
Obviously it hasn’t worked when you say: “it’s running 0.4.9”

Can you see the Photon as AP (with another phone or computer) when blinking blue?

So…in my rush to post a message, my info was a bit inaccurate. I just did a particle identify and it’s indicating the Photon is running 0.5.0.

I’m using the Mac CLI and ran npm update -g particle-cli to be sure it’s current. I’ve had no issues using the CLI with my of my Photons.

I just ran particle update again, and there was no output. I seem to remember lots of output that seemed to stall at the end and I had to hit the “return” key to get it to “finish”.

Yes, I can see the photon on my iPhone and on my Mac (via WiFi Explorer), so I know it’s going into AP mode, but never progresses past step #2 in the Particle app.

Still no resolution on this. I can configure the WiFi via the CLI. However, I cannot get past step #2 when I use the Particle app. I am able to flash new application software.

Any thoughts? It’s running 0.5.0. Is there any other firmware to flash to address possible radio issues?

One last call for advice. If I can’t get the Photon past step #2 with the Particle app, I’m going to advise my friend to return it to Particle with a request for a replacement. Thanks, in advance!

Hi @ctmorrison,

Hmm, okay, so it sounds like this is the situation:

1.) you have a photon that can connect to the internet, it’s running relatively recent system firmware, it’s registered to this person’s account, and you can flash new firmware to it.

2.) when you try to use the android mobile app to setup a new network, it stalls out.

This tells me the photon is working perfectly. My guess is you’re trying to do Soft-AP setup in an extremely dense / crowded Wi-Fi environment where channel 1 is completely blocked by other people’s networks. Can you try doing a setup in a different environment, or just passing the credentials via the CLI ahead of time?

Thanks,
David

Hi @Dave,

I’ll give this a try at home after checking my WiFi network at home to see what channel it’s on. I can see that the Photons appear to use channel 11 (not 1) and there is a relatively strong AP 20’ down the hall from my office. It’s just strange that I’ve used my iPhone (not Android) app for a dozen other Photon’s without issue.

I tried, again, at the office just a minute ago with the “problematic” Photon with the same results–stuck at step #2 on my iPhone Particle app. However, I took another Photon in the same location and it worked fine, as it always has with a dozen other Photons.

I seriously do appreciate your feedback. My “corrections” above aren’t meant to insult, but rather to make sure we’re on the same page. I’ll let you know what happens at home!

Hi @ctmorrison,

Ahh, awesome, that’s good to know, thanks! :slight_smile:

Okay, so that’s really weird. I’m not aware of anything hardware wise that is unique to soft-ap setup that wouldn’t apply to normal Wifi operation. Possible a full-wipe / reflash of the device and DCT configuration region would help.

Lets ping @mdma and @BDub here in case they can shed some light or gather some data on why soft-ap mode might be freezing in the apps. Lets ping @ido as well, maybe there’s a quirk with that android phone or version of the android app?

Thanks,
David

Hi @Dave, same experience at home and there are no channel 11 WiFi networks of any significance in the area. FWIW, step 2 gets stuck with he circle spinning for about 3 seconds and then stops for about 1 second and then repeats the process ad naseum.

Can you point me to a link for a full-wipe / re-flash? I’m happy to do that. I’m clueless about “DCT configuration region.” Quite honestly, I haven’t an idea as to what my friend did before he reached out to me that he was having problems.

Here’s the output from particle serial inspect:

    Platform: 6 - Photon
Modules
  Bootloader module #0 - version 7, main location, 16384 bytes max size
    Integrity: PASS
    Address Range: PASS
    Platform: PASS
    Dependencies: PASS
  System module #1 - version 15, main location, 262144 bytes max size
    Integrity: PASS
    Address Range: PASS
    Platform: PASS
    Dependencies: PASS
  System module #2 - version 15, main location, 262144 bytes max size
    Integrity: PASS
    Address Range: PASS
    Platform: PASS
    Dependencies: PASS
      System module #1 - version 15
  User module #1 - version 4, main location, 131072 bytes max size
    UUID: 2DADF976EC6BA3921CA7C68A8C91C418640F04C89D21EA256AEE2409CB1D97B0
    Integrity: PASS
    Address Range: PASS
    Platform: PASS
    Dependencies: PASS
      System module #2 - version 15
  empty - factory location, 131072 bytes max size
1 Like

OK…here’s something new. I powered down my iPhone and restarted it and I was able to get it to work. I then cleared the WiFi settings on the Photon by holding down the setup button for 10 seconds. I tried again, but with no success UNTIL I powered the iPhone off/on. My iPhone is running 9.3.2 and the Particle app is current – 1.6. Even this technique isn’t consistent. Sometimes it works and sometimes, not.

Well…further testing has shown the above definitely is not consistent. This is exhausting!

quick update…trying via CLI which always worked in the past and the device seems to be stuck on "Asking the Photon to scan for nearby Wi-Fi networks…

This would appear consistent with the failure point using the Particle app. ???