[Photon] Particle Android app error: "Setup process couldn't disconnect..."

I received two Photons last week. One of them works correctly and I was able to set it up in the Android app, connect to it, and switching D7. But at second one after choosing device, choosing wifi network, and setting up the password the Android app stops at the message “Setup process counldn’t disconect from the Photon Wi-Fi network. This is an internal problem with the device, so …”. I reset the device a couple of times including factory reset but the situation has not changed. The device always flashes green after connecting to USB port, but after 3s pressing the Setup button it flashes blue. Please is it a hardware problem or a matter of setting?

  • After the setting the password, and things, what does the Photon do? Does it go to blinking green? or does it go straight back to slow binking blue?
  • Update the firmware via dfu to 0.4.2


are you able to resolve it? Another way is to use a PC to do that.

I have written a guide here: [Howto] Setup photon if docs step fail

@mumblepins, the updates are not a must unless there’s an issue. It looks more like setup process hiccups in this case.

1 Like

The Photon always blinks blue and steadily during setup. Application fails at second step of setting up (As I remember at the time Connecting to wifi network for credentials or so) after cca 1 minute delay. The Photon blinks green only after reconecting USB cable.
Yes, I will try reflash the Photon, but when less “invasive” methods fails.

Not yet. Thank you for the guide. However, I will be able to test it on Monday at the earliest.

I tried connection with Arduino IDE serial monitor. The command “i” works, but the command “w” skips line with “SSID:” without waiting for network name and goes to “Security:” directly, so that it does not connect to wifi after writing the password.

Opps… maybe suggesting the Arduino serial monitor is a bad choice.

Can you use something like Putty?

Yes, I used Putty and writing wifi credentials went well, however the Photon did not connect to wifi. Then I tried all the methods from published guides:

  • I installed photon driver in order to connect the Photon via USB - success.
  • I installed particle-cli and after setting wifi the cli endlessly gained data from. I had to break the script by Ctrl+C - unsuccess.
  • I installed photon-dfu driver - success I refleshed the Photon with 0.4.2 firmware. At second part the final line was error about getting status. - Maybe success.
  • Now the Photon blinks blue right after reboot (reconnection USB cable).
  • However, mobile app fails at first step now with error that it couldn’t get wifi credentials. - unsucess.
  • After refleshing the Photon does not report as USB device more in PC.
  • I tried reset, factory reset, firmware reset with buttons several times with aforementioned procedures at secured wifi (wpa2-psk(aes)) as well as at unsecured wifi without success.

I am afraid that it is a hardware problem. I hope it is just the software one and can be resolved. During weekend I am going to experiment with different wifi network and PC at my weekend house.

Is the Photon blinking green continuously?

After writing wifi credential the Photon blinks cyan (not green) rapidly and continuously with very short yellow blink cca every 1 minute.

Hmm… Havent’ seen this behavior before.

Ping @harrisonhjones

Thanks @kennethlimcp, sounds like it might be a key issue no?

@mrkale can you PM me your device ID? You can follow this tutorial to get it (it works for both Photon and Spark Core)

1 Like

@harrisonhjones you missed out the link above in your post and i have never seen a blinking cyan with YELLOW flashes before.

1 Like

Fixed the tutorial issue and I agree, cyan with yellow is a bit weird. I’ll look into it

Fast flashing cyan with intermittent orange means a problem with the client key. I don’t think flashing blue with intermittent yellow is possible. Could it be the colors are just being confused a little or perhaps appear differently on that unit?

Yes, It could have been orange, not yellow. But it blinks just 2 or 3 times after long cyan blinking period. From support page: Orange flashing: Connection failure, bad handshake

Entirely possible. You can either PM me your device ID and I can check or you can go ahead and perform the keys doctor command.

At keys doctor command openssl fails several times with error “unable to load Private Key” and many subsequent errors 2916, but key files (pem, der) have been created on the PC drive. However, the reseting the Photon and setting up wifi with particle it blinks cyan steadily.

Can you PM me with the exact output from the terminal? Thanks

The terminal output is too long for PM so that I am PMing the dropbox link to listing file to you.