Photon still solid green with 0.4.5


Last week I wrote about my problems with my photon that was unable to connect to any Wifi. No one from Particle offered me a solution, other than copying a standard answer post with procedures that I have already tried and so said my original post. My last reasonable solution was to wait for firmware 0.4.5 to appear and now, that I have upgraded the photon the problem remains the same: it works all the setup procedure using CLI -the Android app fails often to connect to the photon- but after configuring the photon it does not reboot and remains flashing cyan, and after a manual reset it goes to solid green, but does not connect to any Wifi.

I would very much appreciate a solution to have my photon working or an RMA to get a working one.


Have you tried to flash it with manually compiled firmware from the spark github firmware development/latest branch? (system parts + tinker)

@Melx, there is no need to do that.


  • npm update -g particle-cli
  • place the device in DFU mode
  • particle update
  • place the device in DFU mode
  • particle flash --usb tinker
  • hold the SETUP button until the Photon blinks blue
  • release and hold the SETUP button until the Photon blinks blue rapidly
  • particle serial wifi
  • Setup wifi credentials and let me know how things go. :slight_smile:

Ping @corey


Thank you for your help, I have gone through all your steps but the photon still does not connect to my wifi. I have got just one new behavior: when configured with the Andorid App the photon reboots by itself, changing from blinking cyan to blinking green, but after serveral seconds it went back to flashing cyan. After the manual reset it remains flashing green.

My core does connect to this wifi. I have not been able to test the photon after your suggested procedure against other wifi networks, but I did it previously with the same frustrating result.

Thank you again. Please tell me what to do next if you can figure out anything.

Interesting. Are you able to see if the Photon connected to the Wifi network?

Can you move it nearer to the router in case there’s some issue with the distance?

It is not connected, I have seen all the connected devices. And it is not far, in addition, it does detect the network during configuration, but it refuses to connect. It is happening from the beginning, before updating to 0.4.5

Is the network on 2.4Ghz? I have seen it on mine when it connects but the router is trying to assign an IPV6 address (i am guessing)

If you have a mobile hotspot that you can setup on your phone and see if the Photon connects that would be great!

Ok, I will do, but I have tried it before last update. I have tested five networks, and nothing. Another point is that now I cannot set the photon back to flashing cyan. If it happens as before, I will be able to do it when connected to the PC via USB, but now that it uses USB just for power, the SETUP button does nothing.

I will be back with results in a moment.

Flashing cyan is after the Photon successfully connects to the network. It means attempting to connect to the :cloud:

Then I meant flashing blue, sorry. I have tried with the iPhone and the photon does not connect.

To give more information, using the Andorid App the photon began flashing green, then solid green, then flashing blue. I reset it manually and went to flashing green again, and it remains there

Sorry, maybe I was not really precise. I tried to connect the photon to the network created my my iPhone, and it did not connect. I run the App on an Andorid LG, but use the iPhone just as phone.

note: IOS 9 is not yet supported (Sep 14 2015) with our platform. Also, some Android users have been seeing issues with connecting their device as well.

What version of Android are you running? Also, are you using any custom roms?

cc: @ido



My iPhone uses IOS7. On the other hand I have two android devices, one fails to connect to the Photon more often than the other, but at the end both are capable of configuring it. As it is the PC using CLI. The problem is that once configured either way, the Photon does not connect to any wifi. I have tried two WEP acces points, with and without password, one WPA and the WPA2 from the iphone, and also a range extender. My photon has been unable to connect to any of these five devices.

No custom rom used anywhere.

check your email. responded to your ticket

Going forward, would you mind testing it with the iPhone. That one is known to be good, and should be the same everywhere. It doesn’t do anything weird, whereas things might differ from device to device when it comes to routers. That should rule out any problems with access point configurations.
Could you try clearing all credentials from the Photon, set a simple password on the iPhone (test1234), and enter the credentials over serial (be it the CLI or a serial program)? Let us know if that worked for you(?)

I have done it several times, and the last one after updating to 0.4.5. The Photon does not connect to the iPhone.

I have done it again. The Photon, connected to the PC, detected the network created by the iPhone, I entered the password and it started blinking green, then solid green, then blink blue. The iPhone didn´t indicate any device connected to it.

I have received two photons and they do not connect to WiFi in my home. I already tried to upgrade software and reset credentials multiple times. I also tested moving the device to within 3 feet of the wifi-router to make sure it wasn’t a range issue.

-> Each time the unit kept blinking green led

I tried your procedure and it did not solve the issue. However, after running it the LED blinks white for a little while, then quickly blinks multicolor and resume back to white for a little while, etc.

Is your WiFi 2.4GHz only?
Is your WiFi channel less or equal 11?
Is your SSID broadcasted?
What encryption is your WiFi using?
How do you set the WiFi credentials?
Have you tried temporarily deactivating encryption and firewall?
Have you tried with another AP (e.g. your mobile phone)?

1 Like