Cannot connect Photon to WiFi, even with new firmware or CLI

Hi,

I recently bought 2 Photons.
The first one got connected without problems and runs fine.
However, I cannot get the second one connected to the WiFi.

When using the mobile app, I can connect to it and configure the WiFi and I get a message that he is configuring the Wifi on the device, but then an error occurs, that something went wrong and I need to try again.
After doing this about 20 times, I tried using the CLI method: I can also connect and configure the wifi, but then when the check is done if it is connected on the web, it has failed and the Photon is not connected.

I have read the forums and tried to update the firmware (with DFU) to 0.4.4 and 0.4.7 several times, but I cannot solve the problem.

Like I said: I dont think it is the Wifi, since I connected another Photon to this WiFi without problems, and I also tested with different security, channel, passwords,… on my current wifi and also other wifi networks.

Is there anything else I can try?

Thanks,

Joris

0.4.7 should be most stable, so try to use that one.
What color is your LED, that might give an indication of what’s going on?
Have you tried configuring it over serial already? To do so, place it in listening mode, and do particle serial wifi. See if that gets you to breathing cyan.

It is flashing light blue and sometimes a yellow-red flash.
I read this "Flashing “orange”: This sometimes is misdiagnosed as yellow or red and indicates bad device keys"
Is this the case?

http://1drv.ms/1NqBGAT
Like This…